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1 Introduction 

This introduction presents the advantages of using the TextGrid Laboratory and its features 
related to the TextGrid Repository (TextGridRep). The main elements of the Eclipse-based 
environment, such as perspectives, views, and basic tools like Search and Help, are also 
discussed. 
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1.1 Getting Started 

In order to start working with TextGrid, you will need to download the software, register for 
a TextGrid account, and login. 

1.1.1 The Mission of TextGrid 

The primary mission of TextGrid is to provide a virtual research environment (VRE) for 
humanities scholars in which various tools and services are available for the creation, 
analysis, editing, and publication of texts and images. It consists of two main components: 
the TextGrid Laboratory (TextGridLab) and the TextGrid Repository (TextGridRep).The 
TextGrid Laboratory tools and services are designed to reflect the needs of text-based 
humanities disciplines such as philology, linguistics, musicology and art history. TextGrid also 
supports the storage and re-use of research data through the integration of the TextGrid 
Repository, in which research data is preserved and can be made available. The architecture 
of TextGrid is extensible, which means that additional tools and services can easily be added 
and expanded. 

The underlying concept of TextGrid is quite simple: humanities researchers are no longer 
limited by the restrictions of their individual workspace but can work together 
collaboratively on projects with other researchers, independent of location, with the 
guarantee that their data is being stored in a secure and reliable environment according to 
guidelines for good scientific practice. The TextGrid Laboratory (Lab) is an open source 
software that can be started from any computer and provides integrated access to 
specialized tools, services and content. It offers a variety of tested tools, services, and 
resources, allowing for the complete workflow of, for example, generating a critical textual 
edition digitally. In addition to existing tools and services already available in the 
TextGridLab, external functions in the form of additional tools and services can be added. 
The TextGrid Repository (Rep) is an archive that enables the long-term storage and re-use of 
research data. Once documents are published in the TextGridRep, they cannot be removed 
or altered. Updates and new editions may be added, but the original documents will be 
maintained as published in order to follow responsible research practices. A Persistent 
Identifier (PID) service assigns a PID, a unique code consisting of a sequence of numbers and 
letters, to any item published in the Repository, guaranteeing quotability. 

All in all, TextGrid addresses three main groups of users: humanities scholars working on 
research projects and digital editions, software developers creating and implementing new 
services and tools who would like to find an integrated open-source platform for their 
creations, and content providers (such as archives and research institutions) that would like 
to integrate their data into TextGrid in order to make it available to a wider audience. 

1.1.2 Why use TextGrid? 

The TextGridLab and TextGridRep were developed in cooperation with humanities 
researchers and reflect the needs of scholars who want to explore the research possibilities 
available through digital methods, either individually or within a community of 
geographically-dispersed researchers. Increasingly, many projects in the humanities dealing 
with complex research topics and large amounts of data involve scholars with different 
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backgrounds and expertise; interdisciplinary research and collaborative partnership are 
made easier by using an integrated workspace such as TextGrid in which project and user 
administration is an integral component. Using TextGrid, scholars can conveniently and 
productively work together in a secure environment in which research data is reliably and 
securely stored. The tools and services available in TextGrid are flexible, expandable, and 
adaptable to various research methods. In addition, these tools will be maintained and 
updated to ensure long-term access to and re-use of research data. 

A virtual research environment such as TextGrid makes possible new forms of collaboration 
and research in a secure and reliable workspace. TextGrid offers the following features for 
facilitating humanities research: 

Administration and Workflow Organization 

These consist of core services to administer and organize projects: 

 a sophisticated user management that oversees the assignment and administration 
of roles and access rights for different project partners. 

 an efficient document management system that effectively manages projects and 
objects on different levels and reflects the complex relationships between them. 

 a Workflow Tool which enables the semi-automatic processing of data. 
 a version management to ensure that the work process is comprehensively 

documented via interim revisions. Documents that are “published” in a final form to 
the TextGrid Repository cannot be deleted; however, updates and new versions can 
be added. 

Decentralized Workspace 

Users can access the TextGridLab and TextGridRep independent of location and work 
together on complex research projects. 

Standardization 

The controlled metadata vocabulary and open standards facilitate the exchange of data, text 
retrieval, and digital archiving. 

Expandability 

TextGrid is extensible and enables users to enhance existing tools or to plug in new tools and 
services, either as external web services or as interactive tools using the Eclipse Rich Client 
Platform. 

Modularity 

The TextGridLab is modular in design, with the XML Editor serving as the core element on 
which the VRE is built. A large number of tools and services are associated with the XML 
Editor and can be arranged and combined according to the individual needs of the project. 
Some tools allow the insertion of elements into the source text of the XML Editor; others 
have a structural connection to the XML Editor. The open interface also allows for the 
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integration of new, specially developed applications. This modular structure facilitates work 
processes in the virtual research environment. 

Assignment of User Rights 

TextGrid provides a sophisticated role-based access control (OpenRBAC) system to manage 
access rights. Each TextGrid Project must have at least on Project Managed assigned to it, 
and this role has the right to delegate (assign and remove) additional roles to other users. 
Only users who have been assigned a role in a Project have access to its unpublished 
content. Using this system, user roles can also be assigned temporarily, such as when short-
term participation is necessary in a Project to perform a specific task. In this way the Project 
Manager(s) can control the accessibility to the project data, thus guaranteeing secure and 
reliable teamwork and data storage in a research environment accessible worldwide. 

Distributed Storage 

The TextGrid Repository has distributed storage which consists of two main parts. The initial 
activation, creation, and editing of files is saved in the TextGridRep. The data is stored and 
secured in a search index and has no persistent identifier. The first search index (Search 
Index 1) is dynamic, which means that it contains data which can be only accessed by a 
TextGrid Lab user who has been assigned access rights by the Project Manager(s). This data 
can only be modified or deleted by those who have been assigned a role that allows them 
the authority to edit and delete. 

After the Project Manager(s) decide to publish the data in its finalized format, the data is 
transferred to the second search index, Search Index 2. The data then disappears from 
Search Index 1 and is provided with a unique PID in order to be referenced uniquely. The 
files that have been transferred and “published” can no longer be changed or deleted. Later 
modifications to the data can only be carried out by copying and re-importing a file back to 
Index 1. 

Search Index 2 is accessible to everyone with access to the World Wide Web. Its character is 
static, which means its data is unchangeable. Huge data amounts can also be uploaded from 
other archives or publication servers and made available through the TextGridRep. Both 
TextGrid Lab users and the general public can browse Search Index 2. After using the Search 
Tool in TextGrid Lab, the user receives a list of results. These search results are an accurate 
reflection of the TextGridRep inventory. They are presented in exactly the same order as the 
search results in the TextGridRep that appear after a search has been performed on the 
TextGridRep website that is available without logging in to the TextGridLab. 

1.1.3 Download 

The current version of the TextGridLab (TextGridLab Base) consists of the base components. 
The Lab is available as a free download from the TextGrid website: www.textgrid.de 

German: 

http://www.textgrid.de/2-0/download.html 

https://dev2.dariah.eu/wiki/display/TextGrid/www.textgrid.de
http://www.textgrid.de/2-0/download.html
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English: 

http://www.textgrid.de/en/2-0/download.html 

for various operating systems. Before you can use the software, you must install a Java 
Runtime Environment (JRE) version 6 or higher. You can download the most recent version 
from the Java website: 

http://java.com/download 

1.1.4 Marketplace 

The TextGridLab is available for download as a basic package which contains the most 
important components. The download of additional open source tools and services (free of 
charge) is possible via the Eclipse “Marketplace” interface within the TextGridLab via the 

menu bar at the top of the screen. Please select the  icon   on the Welcome Screen or 
“Eclipse Marketplace ...” under the menu item “Help” in the menu bar. The number of tools 
here is extensible. 

1.1.5 Account and Registration 

Many functions are available without logging in, such as read-only access to published 
information and working with local files. To be able to store your own data in the TextGrid 
Repository, however, you will need to identify yourself and login. If your institution 
participates in the DFN Shibboleth federation, you may simply use your institutional login. 
Alternatively, you can register for a TextGrid account from the TextGrid website 

German: 

http://www.textgrid.de/1-0/registrierung.html 

English: 

http://www.textgrid.de/en/1-0/registrierung.html 

After your registration has been confirmed, you will receive an e-mail containing your access 
information. 

1.1.6 Welcome Screen and Login 

After installing the TextGrid Laboratory, you will be able to start the software. The Welcome 
Screen provides several options: 

 Login to the TextGridLab 
 Use the Search and Dictionary Search (available without login). 

http://www.textgrid.de/en/1-0/download.html
http://java.com/download
http://www.textgrid.de/1-0/registrierung.html
http://www.textgrid.de/en/1-0/registrierung.html
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Once you click “Login”', a new window opens. You will be able to login using your TextGrid 
account information (the user name and password you received via e-mail), or you may 
choose to login via DFN-AAI (= authentication and authorization infrastructure of the 
German National Research and Education Network). If you have forgotten your TextGrid 
account password, please use the button “Forgot Password?'' at the bottom of the screen. 
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After your first login, you will be asked to complete your user information and to accept the 
“TextGrid Terms of Use”. If you select the option “Searchable'', other TextGrid users will be 
able to find you by searching for your name, institution, or e-mail-address. The fields with an 
* are mandatory. You can change your user information at any time via the “Help > 
Authentication'' in the menu bar of the Lab. 

 

After you have successfully logged in, the Welcome Screen will appear with your TextGrid 
login in the center. Now you can begin to use all the tools displayed on the Welcome Screen: 

    
Project & User Management 

 

Search 

 

Text Image Link Editor 

 

XML Editor 

 

Dictionary Search 

 

Aggregations Editor 

These tools are explained in separate chapters of the TextGrid manual and online help. 
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1.2 User Interface 

In this chapter you will find information about the surface structure of the TextGrid 
Laboratory work bench. The Eclipse-based graphical user interface consists of general menu 
bars and tool-specific perspectives. For more information, see 
http://www.eclipse.org/documentation/. 

 

1.2.1 Bars 

The menu bar at the top of the screen offers hierarchical access to most of the functions 
available in the TextGridLab. The toolbar below offers quick access to the most frequently 
used tools and components, plus some tool-specific functions. Use the perspective bar to 
the right of the toolbar to switch between tools you have already opened and using in this 
session. The title bar is explained in a later section (under “Views”). 

 

1.2.1.1 Menu Bar 

The menu bar at the top of the screen displays some of the menu items. It consists of the 
following items: “File”, “Edit”, “XML”, “Tools”, “Window”, and “Help”. 

http://www.eclipse.org/documentation/
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Under the item labelled “File” you can manage: 

 manage Aggregations 
 create, open, save, and close Projects, Objects, and local files 
 manage Revisions 
 Publish  
 open an Object via its URI or copy the URI 
 manage  Metadata  

  Import  and Export  
  hide network warnings 

  restart  or exit  the TextGridLab 

If the oXygen XML editor is installed, a URL for a FTP or SFTP connection can be opened with 
the oXygen WebDAV support. 

The item labelled “Edit” offers operations for the XML Editor and the Text Image Link Editor, 
such as “Undo”, “Cut” and “Paste” or “Find and Replace”. 

Under the item labelled “XML” you can find functions for working with XML code in the XML 
Editor. Therefore, “XML” will be discussed more fully in the menu bar chapter about the XML 
Editor. 

The item labelled “Tools” allows you to open the most important tools at any time. Using 
the sub-item “Show View” you can open the TextGrid views, i.e. the Navigator, the 
Dictionary Results View, the Metadata Editor and the Unicode Character Table (in addition 
to others that are, for the most part, described in the Eclipse documentation: 
http://www.eclipse.org/documentation/). 

The item labelled “Window” enables you to open a new editor view if an editor is already 

open, using this icon ( ). Furthermore, it offers you options to aid in navigating the 
Laboratory, since you can 

 define the appearance of “fast views” when opened using the sub-item “Navigation 

> Quick Access” 
 open and switch between editors 
 minimize and maximize open editors 
 choose the previous perspective, editor, or view 

In “Window” you can also change the preferences ( ). Most of the possibilities are 
described in the Eclipse documentation (http://www.eclipse.org/documentation/), but some 
preferences will affect the TextGridLab directly: 

 The “TextGrid Content Types and File Extension Mapping” configures the mapping 
between TextGrid Content Types (as regular expression matching the content type 
metadata field of objects) and the internal file extensions. 

 In the “TextGridLab Dialog Settings” the user can choose if CRUD warnings should be 
shown to indicate database problems. 

http://www.eclipse.org/documentation/
http://www.eclipse.org/documentation/
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 In “TextGridLab Server and Proxy,” the proxy server and compressed data transfer 
can be configured. 

There are also some possibilities to change the preferences of different modules that might 
have been installed. 

Under “Help” in the menu bar, you can 

 open the Welcome Screen 
 view and change your authentication data 
 use the Help function 
 report a bug and save the logfile 
 view keyboard shortcuts by clicking “Key Assist...” 
 handle software updates 
 receive additional tools and services via the “Eclipse Marketplace” 
 receive information about the current TextGrid version 

Some modules like the oXygen XML editor also offer some features in the “Help” menu if 
installed. 

1.2.1.2 Toolbar 

Using the toolbar gives you access to the most frequently used tools and components, plus 
some tool-specific functions that are only enabled if special tools are opened. These specific 
functions are described in the following chapters about these tools (e.g. the Text Image Link 
Editor). Here are the permanent items of the TextGridLab toolbar, listed by icon and its 
corresponding function: 

 

opens the Welcome Screen 

 

allows you to create new Projects and Aggregations 

 

saves the currently opened document 

 

opens the Aggregations Editor 

 

opens the Dictionary Search 

 

opens the Text Image Link Editor 

 

opens the Project and User Management 

 

opens the Search 

 

opens the XML Editor 

 

opens the Workflow Tool 

 

opens the Metadata Editor 

 

opens the Metadata Template Editor 

 

opens the Unicode Character Table 

 

opens the Help 

 

closes the current open perspective 
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If other modules such as CollateX are installed, their icons will also appear in the Toolbar. 
These functions are discussed in the chapters about these specific tools. 

1.2.1.3 Perspective Bar 

The perspective bar is at the top of the screen on the right side, underneath the menu bar, 
unless the layout of the toolbars has been modified. The perspective bar allows access to 
perspectives that are currently open. It also provides a way to open a new perspective by 

clicking . By right-clicking on one of the open tabs in the perspective bar, it is possible to 
customize the perspective. 

1.2.1.4 Status Bar 

The status bar at the bottom of the screen on the left side always displays the icon   to 
show views as “fast views”. The user can choose custom “fast views” from a list. The right 
corner at the bottom of the screen displays the TextGrid User ID of the user currently logged 
in. There can be additional information visible in this status bar, such as the title and 
resource identifier of selected Projects or Objects. Depending on the views that are open, 
the status bar may also display other details. 

1.2.1.5 Title Bar 

For information about the title bar, please see the “Views” section. 

1.2.2 Perspectives and Editors 

A specific arrangement of user interface components is defined as a perspective. In general, 
a perspective always consists of several views. A perspective can be customized (saved, 
closed, and reset to its initial setting) by right-clicking on the open tab in the perspective bar. 

The icon  on the toolbar can be used to close a perspective. 

Editors such as the XML Editor are closely related to perspectives, with a few differences: 

 Unless re-arranged, all editors will open in a central area, typically in the middle of 
the screen, and will be visible as tabs stacked on top of each other. 

 Editors must be part of perspectives or else they will be closed. 
 While typically there is one view whose content depends on the selected Object, you 

can open a separate editor for each Object you wish to edit. 
 The editor will stay open until you explicitly close it or the Laboratory itself. 

When editors contain unsaved content, their tab is marked with an asterisk (*). 

1.2.3 Views 

Components with a specific functionality that are re-used in various tools are called views. A 
view (for example the Navigator View) can not be opened until a perspective is open, so 
there has to be a perspective open to contain the view. Views can be opened from icons in 
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the toolbar, by using the menu item “Show View” from the “Tools” menu, or as “fast views” 
from the status bar. 

Each view has a title bar at the top. On the title bar, you can set several default options (via 
the context menu by right-clicking on the view). Here are some of the actions possible: 

 Show a view as “fast view”. By clicking this button, the view opens in the current 
perspective. As soon as you click outside that view, it will be hidden again. 

 Detach a view so that it can be placed wherever needed. 
 Restore a view. 
 Move a view by dragging its title bar with the mouse or move a tab group after 

selecting this option under “Move”. 
 Resize views by dragging the border between screen components or selecting a 

border to change the size of the view. 
 Minimize, maximize or close a view. 

Multiple views can be stacked on top of each other. Only the topmost view is visible. Clicking 
on the title bar of a view that is underneath will make it visible by bringing it to the 
foreground. In the perspective of the XML Editor, for example, the Navigator, the Metadata 
Editor, and the Unicode Character Table are arranged in this way by default. 

1.2.4 Selection and Context Menu 

The contents and functions of the user interface depend on the current selection(s). To 
select a word or an Object in a list or tree, click on it once and it will be highlighted. To select 
multiple Objects, use the necessary keyboard-mouse combination depending upon your 
operating system (using a Microsoft computer, you can press the “Control” or “STRG” button 
and use the mouse to click on it, while on a Mac you can use the “command” button), or use 
the “shift” button with a mouse click to select a range of Objects. You can also combine the 
control and shift keys with the cursor and space keys to select items without using the 
mouse. In a text editor, you can select items to highlight by simply dragging the mouse, or by 
using the shift and the cursor keys. 

The context menu of the TextGridLab contains various commands which differ depending 
upon which perspective(s) or view(s) are currently open. The following chapters will explain 
the expanded tool functions made possible through the context menu. 

1.2.5 Shortcuts 

A list of shortcuts can be found in the Lab by selecting the information on shortcuts in the 
“Help” menu or by clicking Crtl+Shift+L. Here are the main shortcuts: 

[Alt+-] Show System Menu 

[Alt+Shift+Q,Q] Show View 

[Crtl+3] Quick Access 

[Crtl+F6] Next Editor 

[Crtl+F7] Next View 
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[Crtl+F8] Next Perspective 

[Crtl+F10] Show View Menu 

[Crtl+M] Maximize Active Editor or View 

[Crtl+S] Save 

[Crtl+Shift+F6] Previous Editor 

[Crtl+Shift+F7] Previous View 

[Crtl+Shift+F8] Previous Perspective 

[Crtl+Shift+E] Switch to Editor 

[Crtl+Shift+L] Key Assist 

[Crtl+Shift+S] Save All 

[Crtl+Shift+W] Close All 

[Crtl+W] Close 

[F12] Activate Editor 

1.2.6 Preferences 

Because TextGrid is programmed in Eclipse, the User Interface can be changed by using the 
preference dialog of Eclipse. It can be opened by selecting “Window” in the menu bar and 
“Preferences”. The dialog is described in more detail on 

http://help.eclipse.org/indigo/index.jsp 

In this dialog you can also change some preferences that are important for TextGrid. For 
example: If you want to change the font size in the Source View of the XML Editor, you can 
select “General” in the preference dialog. Then you have to choose “Appearence” and 
afterwards “Fonts and Colors” in the tree structure on the left. Select “Basic” and “Text 
Font” in the dialog that appears in the center of the dialog. Click “Edit” to change the font 
size and “OK” and “Apply” to save the preferences. 

http://help.eclipse.org/indigo/index.jsp
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1.3 Search 

The Search Tool allows you to search the contents (e.g. TEI-encoded documents) and the 
Object metadata in the TextGrid Repository simultaneously. 

1.3.1 Open the Search Perspective 

The Search Perspective can be opened in several different ways: 

 Click the icon on the Welcome Screen 
 Select “Tools > Search Tool” in the menu bar 

 Click  on the toolbar 

1.3.2 Search Perspective 

The Search Perspective consists of two views: Search View and Search Results View. 

 

1.3.3 Search View 

The Search View consists of a Search location option and a Simple or Advanced Search 
option. 

The Search location option determines the location in which the search will be performed. 
The two possibilities are to perform a search in: 



 
23 1 Introduction 

 “my projects”: this search is carried out only in those projects in which you have been 
assigned a role that allows you to access the project contents. You can only access 
these projects after you have been authenticated and logged in to the TextGridLab. 

 “public data in the TextGridRep”: this search is carried out in the publicly-accessible 
TextGridRep, which contains all published Objects in addition to external data 
resources. The TextGridRep is also searchable without authentication. 

To perform a search, click the button at the bottom of the Search View labelled “Search” or 
click the magnifying glass icon in the title bar of the View. If you click “Hints on Search,” you 
will receive a short introduction to using the Search View. In both Simple and Advanced 
Search, wildcards can be used in the middle and at the end of a word: * for any number of 
characters, ? for exactly one character. 

1.3.3.1 Simple Search 

In the input field of the Simple Search (that is opened by default) you can enter your search 
terms. There are three different search modes: 

 “Search Fulltext”: only the full-text section of an Object is searched 
 “Search Metadata”: only the metadata section of an Object is searched 
 “Search Both”: both the full-text and the metadata section of an Object are searched 

In the simple full-text search, the search strings can be combined using the terms “and” and 
“or”. Words without these conjunctions are interpreted as “and”. 

The simple metadata search works in the same way as the full-text search. The search strings 
can be combined with “and” and “or”. Another way to search for metadata results is to 
specify the type of metadata. The notation is: metadata-tag:search-term. All possible 
metadata tags can be used with this option. 

1.3.3.2 Advanced Search 

In the Advanced Search mode, you can perform a search with the help of the form provided. 
This form consists of three different sections: METADATA, FULLTEXT, and BASELINE ENC. 
Each section can be selected via checkbox. Selected sections are used for the search request. 
The metadata and the fulltext search can be combined by ticking both boxes, while the 
baseline encoding search can only be executed separately. 

 In the advanced FULLTEXT search, only the text section of an Object is searched. In 
the input field you can enter the search term. If you fill in more than one word, the 
words will be “and” related for the search. By specifying the word distance you can 
declare whether the words should only be found in one document or whether they 
should occur within a specific word distance from each other. 

 The METADATA section in the Advanced Search offers the possibility to search across 
different fields. This form is organized as a matrix. Each row represents the search for 
one metadata field. The field can be selected by a combo box at the beginning of the 
line. The search strings can be entered in the text boxes. These text boxes are “or” 
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related. The different lines are “and” related. The searchable metadata fields can be 
accessed via the drop down menu. They consist of: 

o Data Contributor: a person who submits data in TextGrid, identified by his or 
her user ID (e.g. testuser@textgrid.de) 

o Identifier: an identifier in a non-TextGrid context (e.g. a ISBN or ISSN, a 
shelfmark, a registration or an inventory number) 

o Notes: additional information concerning the Object 
o Project: the TextGrid Project to which the Object is assigned 
o Rights Holder: the person or organization who holds the copyright for an Item 
o TextGrid URI: the internal Uniform Resource Identifier of an Object 
o Title: the title of an Object 

The expandable labels “Text types”, “Content types” and “Languages” contain 
checkable tree controls, which can be used to define the Search closer. With the 
assistance of the “Date” you can be set a time frame. 

 By using the BASELINE ENCODING search (→http://www.textgrid.de/ 
fileadmin/TextGrid/reports/baseline-all-en.pdf), only baseline encoded TextGrid 
Objects can be found. This search form is organized as a matrix. In the first text box 
of a line the search tag should be filled in. In the following text boxes of this line, the 
searched content can be filled in. The text boxes of a line are “or” related. The 
different lines, one below the other, are “and” related. 

1.3.4 Search Results View 

This view lists the search hits found after a search has been submitted. It initially shows the 
titles of the documents and the matches in their context. The title is given with additional 
information about the document type, the Project, the Revision, and the name of the editor. 

The items in the list can be chosen via mouse-click. A double-click opens these with the 
default editor. Right-clicking allows for further actions to be applied to the document, e.g. 
selecting another open action, displaying its metadata, or copying its URI to the clipboard. 
The context menu is in most parts identical to that in the Navigator. 

http://www.textgrid.de/%20fileadmin/TextGrid/reports/baseline-all-en.pdf
http://www.textgrid.de/%20fileadmin/TextGrid/reports/baseline-all-en.pdf
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1.4 Help 

The TextGridLab includes an integrated online help system, which can be opened en bloc 
and can be searched by keywords. The TextGrid Laboratory also offers you a context-
sensitive help. 

1.4.1 Static Help 

The general, unspecialized help can be opened by selecting “Help” in the menu bar. You can 

also choose “Help Contents” , “Open Cheat Sheet” , “Dynamic Help” and “Keyword 

Search”  . 

1.4.1.1 Help Contents 

After clicking “Help Contents”, the general help function is shown in a new window of your 
standard web browser. This new window contains a header in which you can enter a 
keyword for search. If you click “Scope”, you can restrict the search to a specified area. In 
the default mode, all topics are searched. 

The main window is separated into two parts. The left part is similar to the Navigator View. It 
shows a tree structure of all help contents. The right part shows the entries of the help 
content. In the toolbar of the left part you can choose different operations: 

 Print  the selected topic with or without all subtopics.  

 Click   to search for a keyword in the selected topic with or without all subtopics. 
The choice between searching in a topic with or without subtopics can be made after 
clicking the downward-pointing triangle for the drop down menu.  

 Furthermore, you can collapse all nodes in the list below with , minimize and 
maximize the window.  

 Clicking  keeps the navigation tree synchronized to the current topic (that means 
the tree structure shows those terms highlighted which were activated by following 
the links in the selected entry on the right)  

The list below shows the contents in a tree structure. By clicking “+” or “-” button, the 
subcontents can be expanded or collapsed. After clicking a tree item, the corresponding 
content is shown in the window’s right-hand area. 

In the footer of the left part of the navigator you can select between 

 a table of contents   

 a view to search the index   

 a listing of the search results   

 a view of the bookmarks  that can be deleted with  (selected bookmarks) 

and  (all bookmarks) in the toolbar of the view. The right-hand part of the “Help 
Contents” window shows you the selected entry of the help. The toolbar of this right 
part shows some icons:  
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 Use the backward and forward button to navigate and  to get back to the starting 
point.  

 Click  to show the displayed topic in the table of contents in the left-hand part of 
the window, if the contents tree is collapsed.  

 You can bookmark a document  or print the page . 

1.4.1.2 Cheat Sheets 

Cheat sheets can be designed to help a user complete a particular task, and they list the 
sequence of steps required. Currently no cheat sheets are provided for the TextGridLab. You 
have the possibility to select cheat sheets from a local file or an URL. For more information 
see 

http://help.eclipse.org/indigo/index.jsp?topic=%2Forg.eclipse.platform.doc.user%2Freferen
ce%2Fref-cheatsheets.htm 

1.4.1.3 Context-Sensitive Help 

It is possible to initiate the “Dynamic Help”, a type of context-sensitive help from the menu 
bar. A view opens with a forward and a backward button to navigate and a brief description 
of the view or editor that is currently open. If you change to another view, the content of the 
help view changes simultaneously. 

1.4.1.4 Keyword Search 

The Keyword Search can be started by a separate menu item. Enter one or more words in 
the input box and click “Go”. Click the checkmark in the right corner of the input field to 
open a menu with the recent search terms that have been used. You can use wildcards (* for 
any string, ? for any single character and “ ” to demarcate a phrase) and logical operators 
(AND, OR and NOT). 

 Click  to show result categories  

 Click  to show result descriptions.  

 Use  and  to navigate.  

Click the downward triangle in the toolbar of the view to choose between different options 
available during the Keyword Search: 

 If you select “Contents”: The result is presented in a tree structure. Use the “+” and 
“-” button to open or close a branch. Click  in the toolbar to close them all.  

 By clicking “Related Topics,” entries are selected in which the view or editor that is 
currently open will be discussed.  

 Click “Bookmarks” to browse your bookmarked entries.  
 You can also search in the “Index”.  

The result of the search is listed below. You can click on the title of an entry to open it. If an 
entry in the help is opened, the toolbar of the view offers you the option 

http://help.eclipse.org/indigo/index.jsp?topic=%2Forg.eclipse.platform.doc.user%2Freference%2Fref-cheatsheets.htm
http://help.eclipse.org/indigo/index.jsp?topic=%2Forg.eclipse.platform.doc.user%2Freference%2Fref-cheatsheets.htm
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 to show it in an external window that will open in the “Help Contents”.  
 to see the item in the tree-structured table of contents  
 to print and to bookmark it  
 to highlight the search term in the entry by clicking  
 to navigate with the forward and backward buttons  

The footer of the “Help Contents” window provides you with the same options as in the 
header of the Keyword Search: “Contents”, “Search”, “Related Topics”, “Bookmarks” and 
“Index”. 

1.4.2 Dynamic Help 

In most views you will find a question mark icon to open the “Context Help”. Alternatively, 
you can always open it via “Help > Dynamic Help” in the menu bar or by clicking on the 

“Help” symbol  in the toolbar. For example, the blue linked word “Help” in the User 
Management View leads you to information about handling role assignment. Additionally, 
the blue linked expression “Hints on Search” in the Search View leads the user to a context-
sensitive help. 
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2. Object Management and Administration 

In this section, the instruments for managing Projects, Objects and users are explained. In 
this context, there is information about the process of importing, exporting, aggregating, and 
publishing Objects and how to manage their metadata. 
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2.1 Navigator 

The Navigator is a project browser giving the users access to all materials related to the 
Project folder on which they are working. 

 

2.1.1 Open the Navigator 

The Navigator is, by default, part of the Project & User Management module, the Workflow 
Tool, the XML, the Text Image Link Editor and the Aggregations Editor Perspective. The 
Navigator can be opened or re-opened in all perspectives, meaning that a perspective must 
be open to contain the Navigator. To open the Navigator: 

 select “Tools” in the menu bar and then the items “Show View” and “Navigator” 

 click on the Navigator icon  in the toolbar. 

Using the Navigator View requires authentication. At least one perspective must be open to 
start the Navigator. 

2.1.2 Navigator View  

The Navigator View is used for handling TextGrid Projects and Objects. All Projects the user 
is entitled to access are displayed by a folder icon in the tree view that can be expanded or 

collapsed by clicking on the nodes. There is also an icon  which represents the content of 
the TextGrid Repository in the Navigator. The contents are listed by the authors' names. The 
Navigator uses different icons for different types of Objects, e.g.: 

 

XML document 

 

MEI document 

 

Plain Text Object 

 

Image Object 

 

Text Image Link Object 

 

Edition 
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Work 

 

Collection 

 

Aggregation 

For “Edition”, “Work”, “Collection” and “Aggregation”,  see Objects. 

2.1.2.1 Menu Bar of the Navigator View 

Some functions essential for managing Projects and Objects can also be found in the menu 
bar under the item “File”: 

 Click “New Object” to create a TextGrid Object and “New Project” to create a 
TextGrid Project. 

 Objects can be opened with “Open Object” but also with “Open URI”. This identifier 
can also be copied with “Copy URI”. 

 Projects can be deactivated, reactivated or deleted by users who have the necessary 
rights to do so. 

2.1.2.2 Toolbar of the Navigator View 

The toolbar of the Navigator offers you several functions. If someone else modifies the 

Repository contents, you might need to refresh the Navigator View manually. Click  at the 
top of the Navigator View to do so. 

By using the other icons, you can collapse all nodes , or by clicking on the triangle next to 

, you can select between sorting the Projects and Objects by modification date, title, type 

or in their original order and if the sorting should be ascending or descending.  opens a 
filter dialog where you can define which Projects or Objects are shown in the Navigator. You 
can filter by Project roles or Object content types. 

In the view menu, which drops down by clicking the white triangle, you can refresh and 
customize the view. The view can be customized by choosing a filter or selecting the content 
to be shown. You can also link it to an open editor. 

2.1.2.3 Context Menu of the Navigator View 

Context menus will pop up when right-clicking a Project or an Object in the Object tree. This 
allows a user to manage Objects or create new ones. The context menu is different for 
Projects and Objects and it varies depending on what kind of Object has been selected. 

If a Project folder is preselected, you can deactivate, reactivate or delete it if you have the 
authority to do so. The Project will disappear from the Project list until it is reactivated. Its 
published resources will remain readable. You can also deactivate, reactivate, or delete a 
Project by choosing the items from “File” in the menu bar. The Project & User Management 
can be opened directly from here by right-clicking a Project. 

To open an Object, double-click it or right-click it and select “Open”. In accordance with its 
document type, the file will be opened in a default editor. Click “Open With” to choose 
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another editor. To remove an Object, right-click it and select “Delete”. You must have the 
necessary access rights to do so. All Objects can be exported as files from here. Click “Show 
Revisions” to view the file’s history. You can also open or reload the corresponding metadata 
or view the technical metadata. Please see the succeeding chapters for more information 
about the user rights management, the revision control and the application of metadata. 

If an Edition, Collection or Aggregation is selected, the context menu offers the item “Edit”. 
The Aggregations Editor opens if you click here. In the case of Editions and Collections, 
publication via context menu is possible as well. 

The context menu of the Navigator allows you to associate an XML document with an 
adaptor. Images and XML documents can also be added to the Text Image Link Editor. 

To import a copied Object into another Project, you can right-click an Object and select 
“Copy”, then right-click a Project and select “Paste”. You can also copy the URI (Uniform 
Resource Identifier) of a Project or Object to the clipboard so that it can be used by other 
applications different from TextGridLab. If you select “Show CRUD warnings”, you can see if 
there are problems with the database. If SADE is installed, an Object can be published with 
SADE via the context menu of the Navigator. 

2.1.3 Using the Navigator 

 Some of the main tasks of the Navigator View are featured in the following passages. 

2.1.3.1 Create New Projects 

To create a new Project, select “New > New Project” from “File” in the menu bar or from the 
context menu in the Navigator when a Project is marked. Alternatively, you can use the 

downwards directed arrow next to  in the toolbar. The “Project Manager” role, the 
“Authority to Delete” and the “Editor” role will be assigned to you by using the Project & 
User Management. 

 

Enter a name and a description of the Project. By default, the Project & User Management 
will open after you have finished the process by clicking “Create”. If you do not want to 
display this view, click the check box to remove the checkmark. 
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2.1.3.2 Create New Objects 

Click “File > New Object” in the menu bar or “New Object” in the context menu of the 
Navigator when a Project is marked to create a TextGrid Object. 

 

To create an Object, a Project folder and an Object type have to be chosen. If a Project was 
preselected in the Navigator, this Project is suggested in the “Create a New TextGrid Object” 
dialog box. After clicking “Next” the Metadata Editor interface will open. Complete the 
metadata and click “Next”. Depending on the document type the following steps differ. If it 
is an XML document, you can select a schema. After all mandatory information is entered, 
click “Finish” to complete the operation. 

2.1.4 Interaction of the Navigator with Other Components 

Since the Navigator is a tool for managing Projects and Objects, it interacts with the Project 
& User Management, the Metadata Editor, and the Aggregations Editor. 

The Project & User Administration can be opened directly from the context menu of the 
Navigator View. The Project & User Management will also be started by default after 
creating new Projects. 

The Metadata Editor can be opened directly from the context menu of the Navigator View as 
well as metadata can be reloaded. The Metadata Editor interface is part of the dialog for 
creating new Objects. 
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The Navigator is, by default, part of the Aggregations Editor Perspective. It is used especially 
for creating references between Objects and Aggregations, such as Editions or Collections. If 
you right-click an Edition, a Collection, or another Aggregation and select “Edit”, the 
Aggregation Composer will open. 

If SADE is installed, an Object can be published with SADE via the context menu of the 
Navigator. 
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2.2 Project & User Management 

The Project & User Management allows you to create and manage Projects, to add users to a 
Project, and to assign roles to them. 

2.2.1 Open the Project & User Management 

There are several possibilities to open the Project & User Management: 

 Click “Project & User Management” in the Welcome Screen. 
 Select the tool “Project/User Administration” from “Tools” in the menu bar 

 Click the icon  in the toolbar 

2.2.2 Project & User Management Perspective 

The Perspective is subdivided into two views. The Navigator is on the left, and the User 
Management View is on the right side. 

 

2.2.3 Navigator View as Part of the Project & User Management Perspective 

Projects in TextGrid are used to manage access to Objects. All TextGrid Objects belong to a 
Project. Objects belonging to a Project are listed in the Navigator. To manage an existing 
Project, select it in the Navigator by left-clicking on it with the mouse. The users associated 
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with this Project are shown in the User Management View. To handle Objects and Projects, 
use the Navigator. 

2.2.4 User Management View 

When a new Project has been created, Project users can be added and roles can be assigned 
to them. To be selected users must previously have logged into TextGridLab at least once. 
There are four possible roles for users in TextGrid and every role has specified rights: 

 Project Manager delegate, create rights for Projects; delegate, publish rights for resources 

Authority to Delete delete rights for resources 

Editor read, write permission for resources 

Observer read only rights for resources 

  

  Project Rights Resource Rights 
   

Delegate 
edit the user/role 
assignment for the 
Project 

modify rights for the resource 

Publish   
publish a resource. The resource will be then 
world-readable and cannot be deleted or updated 
any longer 

Delete   delete unpublished resources 

Create Create new Projects create new resources in the Project 

Write   write (i.e. update) unpublished resources 

Read   read resources in the Project 

Rights in TextGrid are non-hierarchical. If users are meant to have full rights, the roles 
“Project Manager”, “Authority to Delete” and “Editor” must be assigned to them. Roles with 
their respective rights can be withdrawn from users by those with the authority to do so. 

2.2.5 Using the Project & User Management 

Here are the steps to add new members to your Project: 

1. Search for new users by name, e-mail address or organization. * matches any letters. 
You can browse all registered and searchable users by filling in an asterisk * only. 
When clicking “Search Users” or pressing the enter key, the checkbox “Show Search 
Results” is automatically activated and the results are shown in the list of users above 

with the icon . You can also look for new members by listing users you have 
worked with in previous Projects. Tick “Show Contacts” to do this. Your contact 

persons are marked with a special icon . 
2. Choose the roles for the prospective Project members by marking the boxes next to 

each user. Changes not yet applied are displayed in red boxes. 
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3. As soon as you click “Apply Changes” the background of the boxes becomes white 
and the icon in front of the names added to the Project changes into another symbol 

. The users are now members of your project. Click “Revert Changes” to remove 
changes that are not yet applied. 

2.2.6 Interaction of the Project & User Management with Other Components 

The User Management interacts with the Navigator that is mainly used for managing 
Projects and Objects. The Navigator View is part of the Projects and User Management 
Perspective. By right-clicking a Project in the Navigator the User Management can be 
started. 
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2.3 Import 

 The Import function is used to open and save files in TextGrid that were not originally 
created in the Laboratory, or Objects that are stored in the Repository and have to be 
imported into the Laboratory for editing. Other Objects have been previously exported from 
the Laboratory, so that they have to be re-imported for editing. 

 While files are identified using file names and paths, each TextGrid Object is identified by an 
URI (Uniform Resource Identifier) that will be generated during import. If a set of files that 
link to each other is to be imported, these links will have to be rewritten to use TextGrid 
URIs instead of file names to work. The TextGridLab comes with a set of configurations for 
common file types which you can choose in the Import and Export Tool. 

2.3.1 Open the Import Tool 

A perspective must be open to use this tool. Click “File” in the menu bar and choose the 
menu item “Import local files ...”. 

 

2.3.2 Using the Import Tool 

The Import Tool can be used not only to import local files as TextGrid Objects but also to re-
import them with or without their metadata afterwards. 
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2.3.2.1 Import Local Files 

 Import files from your local operating system or a storage medium into the TextGridLab: 

1. Select a target Project into which the files should be imported in the drop down 
menu at the bottom of the tool. 

2. Drag files or folders from the file management application of your operating system 
to the list in the Import Tool. As an alternative to dragging and dropping, click “Add” 
on the top of the Import View to replenish the list below with a file. Use the 
“Remove” button to remove a file from the list. 

3. The Import Tool suggests a content type, Object title, and rewrite method. You can 
modify the proposed title, content type or rewrite method of an entry by directly 
clicking the appropriate entry in the table, or adjust additional metadata by selecting 
an entry in the list and using the Metadata Editor. 

4. Click “Import” to finish. After the import has finished, a result screen will list all files 
that were imported, along with confirmation or warning and error messages if the 
import was unsuccessful. 

5. You can optionally save the import specification (this is the list of original file names 
imported together with their associated TextGrid URIs and rewriting methods) in 
order to make it simple to re-export the same set of Objects later. The import 
specification can be saved as a TextGrid file or as a local file. Use the buttons at the 
bottom of the view. 

2.3.2.2 Re-Import TextGrid Objects 

You can re-import Objects that have previously been exported. During the export process, 
the file itself and another file including its metadata are saved on the external storage 
media. By choosing from the target Project dropdown box in the Import View, the Object 
can either be re-imported as a completely new Object with a new URI or as a new Revision 
of the Object previously exported. 

Re-import a file as a completely new Object 

Export the Objects from TextGrid first. After the export they will be saved as local files on 
your operating system.  

1.  Open the Import Tool via “File > Import local files ...” in the menu bar. 
2. Choose the target project to which the previously exported TextGrid files will be re-

imported. Then, click the button “Add” in the Import View or “File > Open local file 
...” in the menu bar to select the files in your operating system to be re-imported. 
You can either simply select the files themselves or files together with their related 
metadata files and click “Open”. They will now appear in the Import View. Adding 
files via drag & drop to the Import View is also possible. Every file added to the 
Import View will appear with details (local file name, TextGrid URI, title, and format) 
and is not yet re-imported. The new URI has not yet been generated. If you highlight 
the file in the Import View via left-click, its metadata will be opened. Here you can 
add additional metadata or change its title. 

3. Click “Import” to finish the operation. 



 
39 2. Object Management and Administration 

Re-import a file as new Revision of the former Object 

Export the Object or Objects from your Project folder first. After the export they will be 
saved as local files on your operating system. 

1. Open the Import Tool via “File > Import local files ...” in the menu bar.  
2. Add the previously exported file(s) to the Import Tool View. You can do this by 

selecting the “Add” button or via drag & drop.  
3. Select the original Project folder, from which the file(s) were exported, in the combo 

box below. Be sure that the selected Project folder is named “Project name - new 
Revisions”. As soon as you select the folder, the former TextGrid URI(s) will be 
recognized.  

4. Now click “Import” and the file(s) will be saved as new Revision(s) to the original 
Project. 
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2.4 Export 

The Export function can be used to export TextGrid Objects and their metadata to a local 
hard disk or a storage medium. During the export process, the tool will create two files for 
every Object that has been exported to the target directory on the local operating system: 
one for the data named with the Object’s URI and an additional file that contains the 
Object’s metadata in XML form. For complex Objects like Editions, directories are created 
that list their contents. 

2.4.1 Open the Export Tool 

Click “File” in the menu bar and choose “Export from TextGrid” or select one or more 
Objects in the Navigator or Search Results View and choose “Export from TextGrid”. 

2.4.2 Using the Export Tool 

1. Via the drag and drop function you can add Objects from the Navigator to the Export 
Tool dialog. If you add an Aggregation, all aggregated Objects will also be added to 
the list, and appropriate link rewriting options will be selected. Use the “Remove” 
button to take an Object out from the list. Below the list of Objects, the target 
directory has to be selected. Use “Browse” to specify the target directory. 

2. Click “Export” to finish. After the export has finished, a result screen lists all files that 
were exported as well as warning or error messages if necessary. The Export Tool will 
create two files for every Object: one for the Object itself and one for its metadata (a 
META file, which can be opened with a simple text editor, e.g. Notepad from 
Windows). For complex Objects like Editions, directories are created that list their 
contents. 

3. You can optionally save the export specifications (i.e. the list of all Objects exported 
together with the rewriting methods and file names used) from the result screen. 

4. After a file has been exported, the exported file or Object will remain in the TextGrid 
Repository and therefore also in the Project from which it has been exported. 
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2.5 Revisions and Locking Mechanism 

Revisions are a means to save a specific state of a document, e.g. as an interim result of a 
digital edition. New Revisions are explicitly created by the user, and all Revisions of the same 
base Object are in the same Project. TextGrid uses an mechanism to lock an Object if a user 
is working with it. A second user will receive a message when opening the same Object if the 
first user is still working on it. He or she has then only the right to read but not to change the 
document. 

2.5.1 Using Revisions 

A new Revision of an opened and changed document can be created by selecting “Save as 
new Revision” under the “File” item in the menu bar. If a user wants to save a file that has 
been changed by another user, TextGrid sends a warning. Then the user can save his or her 
new Version as a new Object or a new Revision. 

All Revisions of an Object can be seen by right-clicking on the Object in the Navigator or the 
Search Result View and by selecting the context menu item “Show Revisions”. A list appears 
with all Revisions, the title of the document, the corresponding Project, the contributor, and 
the creation date of the Revision. Every Revision can be referenced by an URI that contains 
the Revision number, i.e. the last digit of the character string (e.g. textgrid:15k34.2). To refer 
to the earliest available Revision, look for the URI without the Revision number (e.g. 
textgrid:15k4). 

2.5.2 Interaction of Revisions with Other Components 

In the cases of Editions, Collections and other Aggregations you can right-click these Objects 
and select “Edit”. The Aggregations Editor will open. If you right-click the Object in question 
in the Aggregations Editor View and select “Revision” you have then the possibility to refer 
to the latest Revision, the Revision to which the selected Object corresponds, or to any other 
Revision from a list. 
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2.6 TextGrid Objects 

TextGrid manages Objects and the types of relations between them. These relations express 
themselves in Aggregations, Editions and Collections, which are themselves TextGrid 
Objects. To create relations between Objects, every Object has to be identifiable. To make 
possible a further identification of the Objects and a cross-Project Search, the Objects have 
to be described by metadata. 

2.6.1 Objects 

Objects are the basic building blocks and smallest unit of data in TextGrid. If you store 
something in TextGrid - be it an XML document, an image, or any other kind of data -, it will 
be saved as one or more Objects. 

An Object consists of a metadata record and content. Both will be handled together: When 
you edit an Object’s content in an editor, you can always switch to the Metadata Editor to 
modify the Object’s metadata, and the metadata record will be saved whenever you save 
the Object. You can view and edit mainly descriptive, bibliographic metadata using the 
Metadata Editor. All metadata for an Object can be reviewed in a dialog opened by the item 
“Show technical metadata” in the Object’s context menu. 

Each Object is identified by an URI (Uniform Resource Identifier) in a form such as 
textgrid:74k0.1. The URI is automatically generated when an Object is saved to the 
Repository for the first time. New Objects that have not yet been saved will be identified by 
a temporary URI. You can copy the URI to the clipboard using “Copy URI” from the Object’s 
context menu, or you can review it in the “Show technical metadata” dialog. In addition, the 
URI of an Object is visible in the status bar when you select it in the Navigator so that it is 
highlighted. 

Every Object has a format or content type: This is a required metadata field that specifies the 
(technical) format of the content. Examples are text/xml and image/jpeg, but there are also 
some special TextGrid-specific content types like text/tg.aggregation+xml . Each Object with 
a specific URI appears in exactly one Project. Projects are containers for the user rights 
management. Each TextGrid Object is either an Item , an Edition, a Work or a Collection - 
these Object classes have different metadata and semantics. 

2.6.2 Items 

Items are the simplest, but also most common entities in TextGrid. An Item may be a page 
scan or a chapter of an edition in the form of an XML document. A range of Items can be 
created via the green cross icon in the toolbar: XML documents, Text Image Link Objects, 
plain text documents, stylesheets and musical notation sheets. Items are dependent Objects: 
They can only be published as part of an Edition or Collection but not by themselves. 
Descriptive metadata for an Item generally consists of one or more titles of the file, its 
format, a rights holder, and the identifying technical metadata that is available for all 
Objects. To associate more sophisticated metadata such as an author or a source description 
with an Item, put it into an Edition and optionally associate a Work. For more information 
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about how to put Items into an Edition or to associate a Work to an Edition, please see the 
chapter “References between Objects”. 

2.6.3 Aggregations 

An Aggregation is a TextGrid Object that consists of an ordered list of references to other 
TextGrid Objects which can also be Aggregations themselves. Aggregations are used to 
organize TextGrid Objects. They are used in a way similar to file system folders, but are more 
flexible: An Object can be referred to from multiple Aggregations, and you can collect 
Objects in your Aggregation that belong to other people and that you can only read. When 
you delete an Aggregation, the aggregated Objects will usually remain – unless you 
explicitely give the command to delete them. See the checkboxes in the delete dialog box. 

There can be different kinds of Objects in an Aggregation differing in their semantics and 
their metadata, but all have the same sort of content: simple Aggregations, which just have 
Item metadata and can be used, e.g. to represent a chapter in a book, which is split across 
various files. Editions or Collections are also Aggregations defined by a characteristic set of 
metadata. Use the Aggregations Editor  to arrange Objects in a nested set of Aggregations. 

2.6.4 Works 

A Work is an individual creation, for example a literary opus, which can be available in 
various editions, e.g. as a pocket edition, as part of a series of collected works, as a theatrical 
performance or as an audio book. An Edition is always a particular edition of a work. To 
describe a Work, TextGrid offers Work Objects: These are metadata-only Objects that 
contain work-specific metadata such as the uniform title, the date of creation or keywords 
describing the Work. By the time of publication, every Edition Object must be linked to a 
Work Object. 

2.6.5 Editions 

An Edition is the manifestation of a work. An Edition is a special kind of an Aggregation, and 
its metadata contains fields to describe, for example, the people and organizations involved 
in preparing the edition or the source (outside TextGrid, e.g. a book) that the electronic 
edition represents. An Edition is often associated with a Work in its pre-publication form and 
it must be associated with a Work for publication. The actual content of an Edition is stored 
in the Item Objects which the Edition aggregates. Editions can be published if they have 
correct metadata, are associated with a Work, and contain at least one Item. The Edition 
Object provides the precise structure for the publishing of Items. 

2.6.6 Collections 

The Collection is an accumulation of TextGrid Objects formed by the membership of a 
particular organisation and/or topic. Collections are intended for two use cases: In an 
organizational context, an Edition may be part of a Collection (e.g. the combination of 
editions from the Blumenbach project under the “Blumenbach” label or the combination of 
digitized prints of the 18th century under the label VD 18). Additionally, Collections can be 
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used to aggregate Items for which the Edition/Work concept is not applicable, i.e. 
digitizations of museum pieces. Collections are valid starting points for publication. 

2.6.7 References between Objects 

The user can create relations or references between certain kinds of Objects in two different 
ways. 

1. To assign an Edition to a Work use the metadata form for the “Edition” Object. To 
open the mask for the metadata input, click on the Edition in the Navigator, right-
click and choose “Open Metadata”. The Metadata Editor will open. Now scroll down 
to the “Edition of” field and click on the “Browse ...” button. Relevant Objects for this 
action are shown. If you choose a Work, its TextGrid URI will be shown in the input 
field. Now the relation between Work and Edition is established. 

2. Creating a reference between Items and Editions or Collections is only possible via 
the Aggregations Editor. Right-click on an Edition or a Collection in the Navigator and 
choose “Edit”. As soon as the Aggregations Editor opens, one or more Items can be 
dragged from the Navigator and dropped into the respective Edition or Collection. 
Users can see which Edition an Item belongs to in the Navigator tree or in the “Part of 
Edition(s)” field in the metadata application form of the Item. Open the metadata of 
the Item, in the way described above, to see if it is related to an Edition. 
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2.7 Aggregations Editor 

With the Aggregations Editor, users are able to choose and put together Objects via drag and 
drop instead of looking for single Objects dispersed in several Projects. Objects relevant for a 
certain topic or research interest can be aggregated. They appear in the Navigator as an 
Aggregation, which can be edited, expanded and dissolved again without deleting the 
Objects within. 

2.7.1 Open the Aggregations Editor 

The Aggregations Editor can be opened via creating a new Aggregation or editing an already 
existing Aggregation, Edition, or Collection. The Editor will open 

 after choosing “New” from “File” in the menu bar and creating a kind of Aggregation 

 by clicking “  > Aggregation” in the toolbar 
 by right-clicking an Aggregation, Edition or Collection in the Navigator and selecting 

“Edit” 

If “File > New” in the menu bar or  are selected, then the “Create a new TextGrid Object” 
dialog box will open. Afterwards, the Aggregations Editor appears. 

You can also open the Aggregations Editor in a separate perspective by using 

 the item “Aggregations” on the Welcome Screen 
 “Aggregations” from “Tools” in the menu bar 

 the icon  in the toolbar 

In these cases, a perspective opens with the Navigator, the empty Metadata Editor and the 
empty Aggregations Editor. To add a new Aggregation, choose “New” from “File” in the 

menu bar or click  in the toolbar. To edit an Aggregation, right-click it in the Navigator and 
select “Edit”. 

2.7.2 Aggregations Editor View 

The Aggregations Editor is part of a perspective with the Navigator and the Metadata Editor. 
If an Aggregation is edited, the toolbar and the context menu of the Aggregations Editor can 
be used. 
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2.7.2.1 Toolbar of the Aggregations Editor 

To manage Aggregations, the Aggregations Editor provides several functions in its toolbar: 

 Click  to create a new Aggregation, Edition or Collection that is subordinated to an 
existing one 

 Click  to remove a selected Object from the list below 
 Click  or  to expand or collapse all branches 

2.7.2.2 Context Menu of the Aggregations Editor 

The context menu in the Aggregations Editor offers you the same options as the toolbar of 
the Editor plus two additional options: 

 using “Rename Item”, any Item can be renamed 
 using “Revision”, you can “refer to this Revision”, to “the latest Revision”, or to any 

other existing Revision 

If you choose the last option, a new “Refer to Revision” window will open that lists all 
Revisions of an Object with the number of the Revision, the title, the corresponding Project, 
the data contributor, and the creation date. Select the Revision you want to revert to by 
clicking on its number and confirm with “OK” or double-click the desired item. After this, the 
Revision number appears behind the corresponding Object in the Editor. 
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2.7.3 Using the Aggregations Editor 

 
To create a reference to an Object in an Aggregation, Collection, or Edition, use the 
Navigator to drag it from there and drop it in the tree shown the Aggregations Editor. You 
can see which Edition an Item belongs to in the Navigator tree or in the “Part of Edition(s)” 

field in its metadata application form. Save the changes by using [Crtl+S], the  icon in the 
toolbar or “File > Save” in the menu bar. Otherwise a dialog box will open that reminds you 
to save changes if you quit the Aggregations Editor. 

2.7.4 Interaction of the Aggregations Editor with Other Components 

The Aggregations Editor is based on the conception of Objects and interacts with the schema 
that underlies the Metadata Editor. To enable linking Objects and Aggregations, the 
Navigator is opened with the Aggregations Editor by default. 
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2.8 Metadata Editor 

The Metadata Editor is used to create and manage the baseline metadata elements of 
TextGrid Objects. These metadata are used in TextGrid for cross-project searches. The 
metadata input form can be adjusted to individual needs with the Metadata Template 
Editor. 

2.8.1 Open the Metadata Editor 

The Metadata Editor is, by default, part of the XML Editor and the Aggregations Editor 
Perspective and can be accessed in other perspectives in several ways: 

1. by selecting “Tools > Show View > Metadata” in the menu bar, or 

2. by clicking on the Metadata Editor icon  in the toolbar. 

In order to load the Object’s metadata into the Metadata Editor, you must authenticate and 
select a TextGrid Object for editing. 
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2.8.2 Metadata Editor View  

Some fields in the Metadata Editor are generic, while others are specific to certain Objects: 
Items, Editions, Works and Collections. Depending on the Object selected, the fields 
displayed will vary. A few fields are shown collapsed. Click the black triangle in front of the 
element’s name to open it. Some fields are repeatable. They can be opened by clicking the 
arrow beside the designation of the different groups. To add another field, click the “Add 
additional” button as appropriate. Entries that are not required can be removed by clicking 
the corresponding “Remove” button. 

Each input field in the Metadata Editor belongs to one of the following groups: identifiers, 
keywords, dates, persons, or agents. These groups do not correspond to any individual field 
displayed but the fields of the elements belonging to one of these groups have the same 
structure. 

Identifiers are of a special type and they have a characteristic value. Their input fields can be 
inserted with unrestricted terms. The type may be the ISBN, ISSN, URL or Kalliope (please 
see RNA: “Regeln zur Erschließung von Nachlässen und Autographen”). The value is the 
specific number code or address of the Object. 

Keywords have an “id” (= identifying) attribute and a value. The “id” attribute is an 
identification in some controlled vocabulary, e.g. pnd:13414032. The value is the 
information that will be displayed.  

Dates have the attribute “date” or the attributes “notBefore” and “notAfter”. The attribute 
“date” is used for the information when an event occured. Additionally, the original form 
given in a document can be added in the second field. Click “Switch to Data Range” in order 
to use the attributes “NotBefore” and “NotAfter” for the start and the end of the era 
denoted. Use the “Switch to Approx Date” button to return. The mandatory “Approximate 
Gregorian Date” field needs to contain at least four numerals specifying a year. Possible 
values for approximate Gregorian date fields:  

 year (four digits)-month (two digits)-day (two digits), e.g. 2009-01-21 
 year (four digits)-month (two digits), e.g. 2009-01 
 year (four digits), e.g. 2009 

Fields of the type person have the attributes “id” and “corporate body”. Use “id” for an 
identifying URI, e.g. PND or FOAF. “Is corporate body?” can be chosen if wanted. The value 
to be inserted in the field is the person’s name. There is an auto complete function for this. If 
you enter a name of a person, TextGrid will suggest you adequate PND entries. Select on of 
them and the PND number will be added automatically.  

Agents are specified with their name as value and the attributes “role” and “id”. “role” 
means a Dublin Core relator term you can choose from the drop down menu. The “id” 
attribute is used for an identifying URI like PND or FOAF. 
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2.8.2.1 Generic Metadata 

The following metadata are generic. This means that they appear in the application forms of 
all TextGrid Objects: 

1. Object’s title 
2. identifiers 
3. format of Object 
4. notes 

The mandatory “Title” element should be used for the title and subtitles of the Object. 
Remove a title or add an additional title by clicking on the appropriate buttons. 

Add some kind of identifier for the Object in some controlled vocabulary and choose 
between ISBN, ISSN, URL or Kalliope (= RNA) in the drop down menu. ISBN, ISSN, URL and 
Kalliope are common default values but other types can be added if wished. Further 
“Identifier” elements can be added or removed by clicking the corresponding buttons. 

Use the “Format” element to fill in the required information about the MIME type (= 
Internet Media Type ). The field “Notes” can be used for every other kind of information. 

2.8.2.2 Item-specific Metadata 

In the application form of Items (and Aggregations) there are the following specific input 
fields: 

1. Title(s) 
2. Identifier(s) 
3. Rights Holder(s) 
4. Notes 
5. Part of Edition(s) 

In the case of Items, names of rights holders (e.g author, contributor, editor) can be 
attached. In the “Rights Holder(s)” field they can be identified with a name and an URI. 
Further rights holders can be added by clicking the appropriate button. Rights holders can be 
removed by clicking the corresponding button. Mark the box if it is a corporate body. 

The input field with the name “Part of Edition(s)” displays the relation of the Item to an 
Edition Object. The field can not be filled with input by the user. The default entry is “no 
related Editions found” as long as there is no connection made to an Edition Object. This 
entry changes once a relation is defined via the Aggregations Editor. 

2.8.2.3 Work-specific Metadata 

Works are Objects that are essentially defined by their metadata. In contrast to Editions and 
Collections, they do not include other Objects. The metadata form of Works contains the 
following elements: 

1. Title(s) 
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2. Identifier(s) 
3. Agent(s) 
4. Abstract 
5. Date of Creation 
6. Spatial(s) 
7. Temporal(s) 
8. Subject(s) 
9. Genre(s) 
10. Type(s) 
11. Notes 

The “Agent” element for Works is required on publication and it is repeatable. It consists of 
a role attribute for which a Dublin Core (DC) relator term can be chosen from the drop down 
menu. In the “id” attribute an identifying URI like PND or FOAF might be added. The agent’s 
name can be given as the value for this element. The “Abstract” element is optional and 
repeatable. It is used for any comprehensive description of the work. 

The “Date of Creation” element is mandatory. It must be entered on the form TextGrid 
supports. Spatial, temporal and subject keywords can be added. Their identifiers should be 
ideally linked to controlled vocabularies. Each of the three categories “Spatial”, “Temporal”, 
“Subject” has included a value field. With “Value” the display value can be influenced. 

The “Genre” element is required and repeatable. It is used for basic classification. For a more 
detailed classification beyond “Genre”, the “Type” element can be applied. It is optional and 
repeatable. 

2.8.2.4 Edition-specific Metadata 

 When you create an Edition, the metadata form contains the following fields: 

1. Title(s) 
2. Identifier(s) 
3. Edition of 
4. Agent(s) 
5. Source(s) 
6. Form(s) of Notation 
7. Language(s) 
8. License/Copyright 

The “Edition of” element names the related Work Object with a TextGrid URI. To assign an 
Edition to a Work use the “Edition of” field. Relevant Objects for this action are shown by 
using the „Browse” button. If you choose a Work, its TextGrid URI will be shown in the input 
field. Use the link to open the Object and the button to browse the Projects and select an 
appropriate Work Object for the Edition. Creating a reference between Items and Editions or 
Collections is only possible via the Aggregations Editor . 

The “Agent” element is repeatable. Add further agents by clicking the “Add additional 
Agent” button. Type in the agent’s name as the value and select the appropriate Dublin Core 

https://dev2.dariah.eu/wiki/display/TextGrid/Aggregations+Editor
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role from the drop down menu. Agents are identified with an URI, e.g. PND or FOAF. 
Personal names should be typed in the form “surname, first name, middle name”. 

The “Source” element can be an object citation or a bibliographic citation. An object citation 
is used, for example, in the case of an artifact in a museum. Bibliographic citation is used, for 
example, for books (i.e. monographs and anthologies) or journal articles. Click one of the 
buttons to add this information. Use the corresponding buttons to remove source metadata. 

Object Citation: An object citation can consist of a title, information about the contributor as 
well as about the date and a special identifier. “Title” is a required and repeatable element. 
The “Object Date” and the “Object Identifier” type are also required fields. The “Object 
Contributor” element follows the structure of all “Agent” elements; “Date” follows the 
structure of all “Date” elements; and object identifier the structure of all other identifiers. 

Bibliographic Citation: A bibliographic citation consists of the elements 

1. Author(s) 
2. Editor(s) 
3. Title(s) of Edition 
4. Place(s) of Publication 
5. Publisher(s) 
6. Date of Publication 
7. Edition Nr. 
8. Series 
9. Volume 
10. Issue 
11. StartPage 
12. EndPage 
13. Bibliographic Identifier 

Only the “Title(s) of Edition” element, the “StartPage” field belonging to the “Date of 
Publication” element and the “Bibliographic Identifier” type are required. “Title(s) of 
Edition”, “Author(s)”, “Editor(s)”, “Place(s) of Publication”, “Publisher(s)” and “Series” are 
repeatable by clicking the “Add” button. 

Author, editor and publisher are identified with an URI, e.g. PND or FOAF. Check the box if 
they are corporate bodies. Use the “Name” field for the person’s name. Personal names 
should be typed in the form “surname, first name, middle name”. Use the “Value” field for 
the name of the publication place. For the date of publication, all possibilities used for 
“Date” elements can be applied. 

“Edition Nr.”, “Series”, “Volume” and “Issue” are free fields used like their bibliographic 
equivalents. “StartPage” is required but “EndPage” is not. “Bibliographic Identifier” is a 
repeatable element. Choose ISBN, ISSN or URL as type from the drop down menu. The value 
has to be inserted in the “Identifier(s)” field. 

After having finished the input into all the input fields of the “Source” element, choose the 
notation from the drop down menu of “Form(s) of Notation”. For cases with more than one 
writing style the element is repeatable. 
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The “Language” element is repeatable for documents with more than one language. 

The license type or description can be specified in the “License/Copyright” field. The license 
itself can be identified with an URI. 

2.8.2.5 Collection-specific Metadata 

The metadata form for Collections contains the following elements: 

1. Title(s) 
2. Identifier(s) 
3. Collector(s) 
4. Abstract(s) 
5. Collection Description(s) 
6. Spatial(s) 
7. Temporal(s) 
8. Subject(s) 
9. Notes 

Use the “Collector” element for a DC relator term as role attribute, an identifying URI as “id” 
attribute and the agent’s name as the value. The element is required and repeatable. 

The “Abstract” element for comprehensive information about an Object is optional and not 
repeatable. The “Collection Description” field is optional and repeatable. 

Spatial, temporal, and subject keywords can be added. They consist of an identifier ideally 
linked to a controlled vocabulary and a value as it should be displayed. These fields are 
repeatable by clicking the “Add additional Identifier” button. 

2.8.3. Using the Metadata Editor 

Open the context menu of any Object in the Navigator that you want to edit in the Metadata 
Editor. Select “Open Metadata”. The respective input mask opens. Fill in all input fields with 
the requested or required metadata. 

After having completed all required metadata, the record set can be saved by clicking on the 
“Save Metadata” button at the bottom of the Metadata Editor View. Reload all the entries 
by clicking the “Reload Metadata” button beside the “Save” button. 

To copy the external metadata into the header of a TEI object, click the “Copy TEI Header” 
button at the bottom of the Metadata Editor View. The Header can be pasted into the 
source code presented in the XML Editor. The Metadata Editor can also be used to create 
references between certain Objects, namely Editions and Works. 

2.8.4 Interaction of the Metadata Editor with Other Components 

The Metadata Editor is part of the XML Editor. It shows the metadata of the Objects that are 
currently open. The structure of the metadata depends on the kind of Object it relates to. It 
can be adapted to special needs by using the Metadata Template Editor. 
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2.9 Metadata Template Editor 

The Metadata Template Editor enables users to create their own new fields in the Metadata 
Editor for their Projects. You must have the “Project Manager” role in order to work with this 
editor. 

2.9.1 Open the Metadata Template Editor 

To open the Metadata Template Editor, select it from “Tools” in the menu bar. Alternatively, 

you can click on this icon in the toolbar. You can also right-click one of the Projects for 
which you hold the “Project Manager” role in the Navigator and select “Edit Metadata 
Description”. 

2.9.2 Using the Metadata Template Editor 

Initially a Project must be selected. Click “Next” and “Add new Element”. Then a new 
element name must be chosen that can consist of only one word. Now select a data type for 
this element from the drop down menu. The element can be 

 a string: strings range from a single word or character to large blocks of text 
 a date 
 an integer 
 Boolean: this means “false” and “true” values and must be written as “0” and “1” 
 time 
 decimal: must written with a decimal point (for example, “1.5”) 

Mark the checkboxes “Repeatable” or “Mandatory” if desirable. An element can be removed 
by clicking the corresponding “Remove” button. Another element may be added by clicking 
the “Add new Element” button. Click “Finish” to save your input or “Cancel” to close the 
editor. Click “Back” if you want to select another Project. After you have finished creating 
new input fields, they will appear in the Metadata Editor of all TextGrid Objects. 
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2.9.3 Interaction of the Metadata Template Editor View with Other Components 

The Metadata Template Editor enables the user to adapt the metadata to the needs of a 
Project. The interface of the Metadata Editor changes according to the adjustments made in 
the Metadata Template Editor. 
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2.10 Publish 

The TextGrid Publish tool allows users to permanently publish the files that they have used 
in the TextGridLab in the Repository. Only Editions and Collections can be published. Project 
Managers have the sole right to publish them. 

When published, the metadata will be validated automatically. The Objects are freely 
accessible and searchable on www.textgridred.de after publishing. All published Objects 
receive a persistent identifier and all data are migrated to a static storage with backups, 
duplicated, and long term archive services. 

2.10.1 Open the Publish View 

To publish an Edition or Collection, right-click it in the Navigator and select “Publish in 
TextGridRep”. The Publish View will then open. 

2.10.2 Publish View 

The Publish View consists of several levels. 

 The upper level informs you about the status of your Object(s). After initializing the 
view, it will notify you that the Edition or Collection can now be proved. 

 The bottom level allows you to “Proof”, to “Publish” (if proved), and to “Cancel”. 
After clicking “Proof”, the information visible in the upper level changes from “The 
Collection/Edition can be proved now” to “The Collection/Edition is not yet suitable 
for publication” or “The Collection/Edition is suitable for publication now”. 

 In the colored boxes on the middle level you can see how many o.k.'s (permissions), 
warnings, or errors have occurred. More details will be displayed below. The middle 
level is separated into three columns (“Name”, “Status” and “Actions”). If a warning 
or error has occurred, more detailed information can be found in the “Actions” 
column of the list directly underneath. By clicking on an entry in the field “Actions” of 
an error message, a “Call action” button appears. Click on it and you will be directed 
to the source of the error or warning. 

 If no warnings or errors appear on the middle level, an “OK” will appear in the status 
column line and the “Publish” button on the bottommost level will be activated. Click 
“Publish” to finish the operation. This action is irrevocable, meaning that the 
publishing process can not be reversed. 

http://www.textgridred.de/
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2.10.3 Using TextGrid Publish 

Before you publish an Object, it is important to know that only Editions and Collections can 
be published. In order to be published, they must contain a TextGrid “Work”. If an Edition is 
to be published, metadata fields that were previously optional for an Edition become 
mandatory: these fields are “Edition of” and “License”. 

If a Project with at least one Object to be published has been created in the TextGridLab, an 
Edition of this Object can be published by using the Aggregations Editor and the Metadata 
Editor: 

1. Create and save a Work. 
2. Create an Edition. 
3. Copy the Object to be published and the Work with the metadata in the Edition. 
4. Complete the metadata of the Edition: “Edition of” and “License” are required for 

publishing. 
5. Save the Edition. 
6. Publish the Edition. 

This Edition is public now. This action is irreversible. 
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2.10.4 Interaction of TextGrid Publish with Other Components 

The Publish View can be opened directly from the Navigator. “Publish” checks the 
information of the Project & User Management and the Object type as well as the metadata 
before a TextGrid Object is published in the Repository. 
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2.11 Publish Tool SADE 

The SADE Publish Tool is a TextGridLab frontend for publishing data from within the Lab to 
individual SADE (http://www.bbaw.de/telota/projekte/digitale-editionen/sade) installations. 

2.11.1 Install the Publish Tool SADE 

To use the module, you must first install it from the Marketplace. 

2.11.2 Open the Publish Tool SADE 

Open the Publish Tool SADE in one of the following ways: 

1. Select “Tools > SADE Publish” from the menu bar 

2. Click   in the toolbar 
3. Right-click an Object and choose “Publish to SADE” 

2.11.3 Using the Publish Tool SADE 

If no internet destination is defined, a message appears. Before the Publish Tool can be 
used, a SADE instance has to be defined. This can be done after selecting “Window > 
Preferences” in the menu bar and “Sade Publisher” is chosen. A form allows you to define 
the instance via URL and to save a user name and the password. Once this has been done, 
Objects can be published by clicking “Publish to SADE” in the context menu of an Object. For 
more information, please see 

http://www.bbaw.de/telota/projekte/digitale-editionen/sade 

2.11.4 Interaction of the Publish Tool SADE with Other Components 

If installed, “Publish to SADE” can be started from the context menu of the Navigator, the 
XML Editor and, if installed, the oXygen XML Editor. 

http://www.bbaw.de/telota/projekte/digitale-editionen/sade
http://www.bbaw.de/telota/projekte/digitale-editionen/sade
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3 General Object Editing 

This chapter provides an overview of the basic editing tools in TextGrid. During the editing 
process, they can be used for most of the necessary functions. 



 
62 User Manual 2.0 

3.1 XML Editor 

The XML Editor is an interactive tool for editing XML documents and for creating new data or 
annotating text in XML. XML is not a programming language like HTML. It is a markup 
language, which means that XML can work outside the world wide web and sets the 
meaning of the elements and (optionally) their presentation. XML is able to organize and 
classify data in a text. Therefore, XML is able to facilitate the exchange of data and 
information as well as to make it searchable. For more information about XML, please see 

http://www.w3.org/XML/ 

TextGrid’s XML Editor is based on the “Eclipse Web Tools Platform Project” and “Vex” by 
John Krasnay et. al.. For more information, please see 

http://www.eclipse.org/webtools and http://wiki.eclipse.org/Vex 

Please note that this Editor is still part of the TextGridLab, so you will be able to choose 
between the default XML Editor and the customized TextGrid XML Editor. This is important if 
the Preferences should be changed or a XML object is opened via the context menu of the 
Navigator. 

The TextGrid Help explains the TextGrid XML Editor Perspective and its parts in detail and 
provides several examples for using the XML Editor. 

3.1.1 Open the XML Editor 

You can open the XML Editor by 

 clicking “XML Editor” on the Welcome Screen of the TextGridLab. 

 clicking the symbol  in the toolbar. 
 selecting “Tools > XML Editor” in the menu bar. 

3.1.2 XML Editor Perspective 

As soon as you have opened the editor, you will see three main sections: 

1. the Navigator and two hidden tabs on the left. 
2. the Editor Field in the middle, which is blank till such time as an XML Item is opened 

or created. 
3. a separate view on the right, which is split into two different tabs labelled ’Outline’ 

and ’Properties’. These will be blank if no XML document is open. 

3.1.2.1 Features of the XML Editor 

The XML Editor in general offers certain features to make working with XML documents 
easier. 

 

http://www.w3.org/XML/
http://www.eclipse.org/webtools
http://wiki.eclipse.org/Vex
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Show Validation Errors 

Clicking “Show Validation Errors”  under the item “XML” in the menu bar opens a new 
view in which error messages are listed with information about invalid XML and offset. 

Associate a Schema 

If an XML document is open, you can associate a schema to it. After clicking “Associate a 

Schema”  under the item “XML” in the menu bar, the “Select a new schema” dialog will 
open. 

 

Associate a Schema 

If the document is already associated to a schema, there will be a display of summary 
information above the list of schemas. You can choose one of the schemata listed with 
information about the schema name, the corresponding Project, its contributor and its 
creation date. Click a schema to select it and “OK” to associate it to the XML document. 

If no schema is associated, the button “no explicit schema association” on the left below the 
list will be marked. The association of a schema with a document will only be made 
persistent when the document or its metadata is saved. 

Associate a Cascading Style Stylesheet (CSS) 

A Cascading Style Sheet (CSS) can be added to an XML document when it is opened and the 
option to “Associate a CSS Stylesheet” is selected from the item “XML” in the menu bar. The 
CSS will be used for displaying the XML document in the WYSIWYM View. You can select a 
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CSS from the list by clicking on it. By default, a TEI stylesheet built into the editor will be 
used. To reactivate this option, click the button below the list of CSS models. 

Associate an Adaptor 

An adaptor can be associated to translate the selected document to the TextGrid Baseline 

Encoding. To open it, please select “Associate an Adaptor...”  under the item “XML” in the 
menu bar when a document is opened or choose this item in the Navigator’s context menu 
of the preselected Object. A new dialog box will open. 

In the upper list of the dialog, the selected Object(s) will be displayed with information about 
“Title”, “Project”, “Contributor” and “Creation Date”. You can tick the box under this list to 
make the assignment persistent when clicking “OK”. 

In the lower list you can select the adaptor by clicking on it. Here you will also find additional 
information about the adaptors. To reverse your selection, you can mark the button 
“Associate with no adaptor” under this list. 

XML Editor Debugging 

The debugging function finds and reduces the number of problems. The XML Editor 
Debugging works with the WYSIWYM View. Using the “XML Editor Debugging” under “XML” 
in the menu bar, you can reload the WYSIWYM View. By selecting “Debug XML Document”, 
you can save the WYSIWYM Debug Output. You can also open the WYSIWYM Debugging 
View by clicking “Layout Debugging”. 

3.1.2.2 Menu Bar of the XML Editor Perspective 

When you open the XML Editor, certain items in the menu bar will be activated. Some of 
these items are located under “Edit”, and some under “XML”. 

Edit 

When the XML Editor is opened, options from “Edit” in the menu bar can be used, 
depending on the view that is open in the Editor Field. Most items are displayed if the XML 
file is opened in the Source View. These items are listed below: 

 Undo  and Redo : To undo or redo a change made to a document, click “Edit > 
Undo” or “Edit > Redo” in the menu bar. 

 Cut , Copy and Paste : Use “Edit > Cut”, “Edit > Copy” and “Edit > Paste” in 
the menu bar to arrange parts of the source code. 

 Delete  and Select All : For removing sections of code, use “Edit > Delete”. Use 
“Edit > Select All” to mark all source code of an XML document. 

 Find and Replace : To open the “Find and Replace” dialog box, click “Edit > Find 
and Replace” in the menu bar on top. You can specify text to search for and also to 
replace in this dialog box. You can determine: 

o the search direction (“Forward” or “Backward” from the current cursor 
position) 

o the scope (use “All” or “Selected lines” to search within a selected area) 
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o whether or not your search should be “Case sensitive” 
o if the entire search string should be matched using “Whole word” 
o whether to “Wrap search” at the end of the file 
o if the editor focus should move to the first complete occurrence of the text 

you are typing, using “Incremental” 
o if the regular expressions mode should be activated using the “Regular 

expressions” checkbox. Type [Ctrl+Space] over the text field to receive 
content assistance that lists all possible expressions 

 Expand selection to: For marking up passages in the Source View, the option “Expand 
selection to” allows you to select the enclosing, the next, or the previous element. In 
addition, you can restore the last selection. 

 Content Assist: For more information, please see the explanation of the Source View. 
 Show Tooltip Description: Displays tooltip description, where applicable. It shows the 

value of a hover that would appear at the current cursor location. 
 Word Completion: Use this item to receive suggestions from the program for 

completing a word. 
 Quick fix: For more information, please see the explanations of the Source View. 
 Smart Insert Mode: For more information, please see the explanation of the Source 

View. 

XML 

The following operations can be started from the menu bar item “XML”: 

 Insert Elements : Shows a list of possible elements. 
 Rename Current Element to... 

 Source : Used for comment handling and code-formatting. You can also start a 

document cleanup  here. 

 Show Validation Errors  
 XML Editor Debugging 

 Associate a Schema  
 Associate a CSS 

 Associate an Adaptor  

 Copy URI-Fragment : Clones an URI-Fragment for local addressing. 

3.1.2.3 Toolbar of the XML Editor Perspective 

When the XML Editor is open, additional functions in the toolbar will be active depending on 
the view that is currently selected. 

Show Block Markers / Show Inline Markers (WYSIWYM View) 

Click  to show block markers and click  to see all inline markers in the WYSIWYM View. 

Next Annotation / Previous Annotation (Source View) 

By clicking on  or , the next or the previous annotation in the source code can be 
found. By clicking the small triangle next to these icons a list of entities is presented that can 
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be checked. Only the marked kinds of objects will be found. You can select additions and 
changes as well as errors, warnings, and information. You have also the possibility to jump to 
the next or previous annotation. 

Turn Grammar Constraints on and off (Source View) 

When you edit an XML document that has a set of constraints or rules defined by a DTD or 

an XML schema, you can turn the constraints on and off by clicking  or . When the 
constraints are turned on, the XML Editor prevents you from inserting elements, attributes, 
or attribute values not permitted by the rules of the XML schema or DTD, and from removing 
necessary or predefined sets of tags and values. 

Reload Dependencies (Source View) 

If your XML document is associated with a DTD or XML schema that has changed, you can 

reload the dependencies by clicking . 

3.1.2.4 Status Bar of the XML Editor Perspective 

When a document is opened in the XML Editor, the bar at the bottom of the view will inform 
the user if it is writable, if the smart insert mode is active, and lists the current coordinates 
of the cursor (Source View). 

3.1.2.5 Shortcuts of the XML Editor Perspective 

[Alt+/] Word Completion 

[Alt+Shift+Down] Restore Last Expanded Selection 

[Alt+Shift+Left] Expand Selection to Previous Element 

[Alt+Shift+Up] Expand Selection to Enclosing Element 

[Alt+Shift+Right] Expand Selection to Next Element 

[Alt+Shift+W] Show Passage in Navigator, Outline and Properties View 

[Crtl+1] Quick Fix 

[Crtl+A] Select All 

[Crtl+C] Copy 

[Crtl+F] Find and Replace 

[Crtl+I] Format Active Elements 

[Crtl+Shift+/] Add Block Comment 

[Crtl+Shift+\] Remove Block Comment 

[Crtl+Shift+C] Toggle Comment 

[Crtl+Shift+F] Format 

[Crtl+Shift+Insert] Smart Insert Mode 

[Crtl+V] Paste 

[Crtl+X] Cut 
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[Crtl+Y] Redo 

[Crtl+Z] Undo 

[Delete] Delete 

[F2] Show Tooltip Description 

3.1.3 Editor Field 

This section describes how to work with the Editor Field in the center when a document is 
open. At the bottom of the Editor Field, you can choose between three different editing 
views  and one preview mode of the content: “Design”, “Source”,  “WYSIWYM” and 
“Preview”. 

 The Design View shows the hierarchic structure of the document. 
 The Source View shows the document in XML language. It allows you to access its 

structure and modify it. 
 The WYSIWYM (=“What You See Is What You Mean”) View shows an example of the 

display and formatting of the content for the web. 
 The Preview presents a HTML document after treating the XML Object with an 

adequate XSLT file. 

You can switch between those editing views by clicking on the tabs at the bottom of the 
editor. The * in the title bar of the Editor Field shows that the file has not yet been saved. 

3.1.3.1 Design View 

The Design View provides an overview of the tree-structure of the document in the left 
column. The content column on the right side shows the content model of elements, the 
values of attributes, and text content. 

Nodes can be opened and closed by clicking the “+” or “-” button in front of them. You can 
edit the values of attributes, the content of processing instructions, and the text-content of 
elements by typing directly in the appropriate text-field in the ‘Content’ column. You can 
change the position of XML objects by selecting the element, holding down the left mouse 
button, moving the cursor to the target, and releasing the button when the line marking the 
new position is highlighted. 
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3.1.3.1.1 Features of the Design View 

Add and Edit DTD Information 

This menu item is currently not supported . You can convert your DTD to XML schema and 
associate it by using “XML > Associate a Schema ...” as a workaround.  

Add and Edit Schema Information 

A namespace can be chosen using the context menu in the Design View. Select “Edit 
Namespaces...” and the “Edit Schema Information” window will open. The Namespace 
Declarations consist of a prefix, the namespace name, and a location hint. Click “Add” to 
continue. In the “Add Namespace Declarations” window you can choose between selecting 
from a registered namespace or specifying a new one by using the radio buttons. Select 
registered namespaces by marking the boxes in front of them and clicking “OK”. 
Alternatively, a new namespace can be specified. 

The chosen namespace declarations will now be shown in the “Edit Schema Information” 
window. Please click “Edit...”. Enter the required prefix and namespace URI for the 
namespace declaration. Click “Browse” for a location hint. The “Select File” window will 
open. Click “OK” or “Cancel” to finish and return to the “Add Namespace Declarations” 
window. 

As soon as the namespace is specified, finish the operation with “OK”. If no specified 
namespace should be added, click “Cancel”. This will return you to the “Edit Schema 
Information” dialog in which the specified namespace that was previously added is now 
visible. 
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Use “Add” to add further namespaces. Select “Edit” to change already added namespaces. 
Use “Delete” to remove them. Finish the dialog with “Cancel” or “OK” . Once added, 
namespaces can be edited by right-clicking them and selecting “Edit Namespaces...” The 
namespace name can also be changed by left-clicking the corresponding field in the Design 
View. 

Add and Edit Processing Instructions 

Processing Instructions can be included by right-clicking the place where they should be 
added and selecting “Add Child”, “Add Before” or “Add After” and afterwards “Add 
Processing Instruction”. This is not possible when right-clicking on attributes in the tree 
structure. A processing instruction is specified with its target and its data. The “Target” field 
is used to identify the application to which the instruction belongs. The “Data” field contains 
the instructions. Click “OK” to add the instruction. An existing processing instruction can be 
worked on after right-clicking it and choosing “Edit Processing Instruction”. The pop-up 
window has the same format as the “Add Processing Instruction” window. The data can also 
be changed by left-clicking the corresponding field in the content column. 

Add Elements 

Right-click the element under which a new element should be added. You must then choose 
if the new element should be added before or after the right-clicked element or if it should 
be its child element (“Add Before”, “Add After”, “Add Child”). Then click “New Element...”. 
Enter the element’s name and press “OK”. 

Add and Edit Attributes 

Right-click an element and select “Add Attribute” and “New Attribute”. Enter the name and 
the value of the attribute and click “OK”. An existing attribute in the Design View Editor Field 
can be worked on after right-clicking it and choosing “Edit Attribute”. The pop-up window 
has the same structure as the “Add Attribute” window. The value of the attribute can also be 
changed by left-clicking the corresponding field in the “Content” column of the Design View. 

3.1.3.1.2 Context Menu of the Design View 

The context menu of the Design View allows the user to use most of the view’s features via 
right-click. 

 To delete an XML Object, right-click it and select “Remove”. 
 To insert a DOCTYPE declaration in your document, right-click at any position in the 

editing view and select “Add DTD Information...”. 
 To add new or edit existing namespaces in the document, right-click at any position 

in the editing view and select “Edit Namespaces...”. 
 Processing instructions can be edited in a pop-up window after “Add Processing 

Instruction” has been selected. 
 To add an element at a certain position relative to an element in the document, right-

click it and choose one of the elements proposed. When selecting “Add Child”, “Add 
Before” or “Add After”, you can add the following elements: 

o a comment 
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o a processing instruction 

o PCDATA  
o a CDATA section 

o a new element  
 You can add attributes to an element by right-clicking it and selecting from the list 

proposed after selecting “Add Attribute”  . 
 To edit attributes, right-click the attribute in the Design View and select “Edit 

Attribute...”. 

The lists of proposed elements and attributes are provided by Content Assist. Proposals 
come from a referenced content model if a schema is specified for the document, or through 
the XML catalog if a schema is not specified. This will give you “smarter” proposals, such as 
specific child element proposals within a given element, or required attribute proposals. 

3.1.3.2 Source View 

 You can edit a document’s source code in the Source View directly by manually editing, 
inserting or deleting elements and attributes. Lines can be opened and closed by clicking the 
+/- buttons on the left side. Schema-driven Content Assist will support you with a Hover Help 
and lists of proposals when adding new elements. 
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3.1.3.2.1 Features of the Source View 

Syntax Highlighting 

 Tag elements (attributes, values, etc.) as well as comments in the Source View are 
highlighted differently to facilitate orientation in the source code and detection of syntax 
errors. You can customize the syntax highlighting in the editor-relevant preferences. 

Unlimited Undo and Redo 

 To undo or redo a change made to a document, click “Edit > Undo” or “Edit > Redo” in the 
menu bar above. Alternatively, right-click in the Editor Field and select the corresponding 
entry “Undo Text Change”. You can undo and redo every change made to a file for the entire 
editing session. 

Node Selection 

Depending on the position of the cursor in the editor, the node selection indicator highlights 
the corresponding tags as well as the lines that include a node in the vertical ruler in the left 
area of the Source View. 

Comment toggling and block commenting and uncommenting 

 You can toggle an XML comment on and off by right-clicking and selecting “Source > Toggle 
Comment”. To comment on a section of source code, right-click on the selected area and 
select “Source > Add Block Comment”. To delete a comment, select “Source > Remove Block 
Comment”. 

As-you-type Validation 

 While editing the document, errors found in the general XML syntax (such as missing 
quotes, missing brackets, or missing end tags) as well as validation errors (if a schema is 
specified) are indicated by red wavy underlining. A red icon at the top of the vertical ruler in 
the right area of the Source View will appear if the Document contains any errors. To find a 
description of the error, move your mouse cursor over the red marks shown in the vertical 
ruler in the right area of the Source View. A yellow icon indicates a warning. 

 

Smart Insert 

Typing elements and comments is supported by a Smart Insert mode: When you type an 
element, Smart Insert automatically completes the corresponding closing tag. Similarly, 
when you type the beginning of an XML comment <! --, Smart Insert completes the ending of 
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the comment -->. The cursor is left in the middle of the comment tag so that you can 
proceed directly typing in the comment text. In the same line, opening quotes in attributes 
are completed with closing quotes while the cursor is left between them so you can directly 
start typing the value of the attribute. To toggle the Smart Insert mode on and off, click 
“Edit > Smart Insert Mode” in the menu bar and tick or untick the check mark. 

Hover Help  

Hover Help is displayed when users move the mouse cursor over an element or an attribute. 
It displays the content model of the current element or attribute and additional 
documentation information if included in the associated schema. Moving the mouse cursor 
over text that has been marked with red wavy underlining will display a description of the 
current problem. You can modify the Hover Help preferences in the relevant editor 
preferences. 

 

Content Assist 

 When typing the opening bracket < of an element in the Source View field, Content Assist 
provides you with a list of suggested elements allowed at this position. You can activate 
Content Assist by clicking “Edit > Content Assist” in the menu bar at the top. When activating 
Content Assist while the cursor is at an attribute position, a list of suggested attributes 
allowed at this position is provided. Proposals come from a referenced content model if a 
schema is specified for the document or through the XML Catalog. You can modify the 
Content Assist preferences in the editor relevant preferences. 

Quick Fix 

Select “Edit > Quick Fix” in the menu bar on top to see a list of suggested corrections when 
positioning the cursor on a text section text that has been marked with red wavy 
underlining. Alternatively, right-click on the underlined text and select “Quick Fix”. If there 
are no problems or warnings at the selected position, Quick Fix proposals are not available. 

Formatting 

To make the XML document easier to read and better for printing, you can change the 
formatting options in the editor relevant preferences. You can apply formatting to the whole 
document by right-clicking in a non-highlighted area in your document and selecting 
“Source > Format”. To apply formatting to a highlighted area only, right-click in the selected 
area and select “Source > Format Active Elements”. 
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Cleanup 

Simple errors in the XML document such as missing required attributes, missing start or end 
tags, or unquoted attributes can be corrected with XML Cleanup. You can open the 
“Cleanup” dialog box by right-clicking in the Editor and selecting “Source > Cleanup 
Document”. Alternatively, you can find it in the menu bar under “XML > Source > Cleanup 
Document”. Afterwards, set your Cleanup preferences in the dialog box; you can further 
select ’Format source’ in the box to apply formatting to the document. 

Team and Local History 

A local edit history of an XML document is maintained when you create or modify the 
document. This history is accessible via “Team > Show Local History” in the context menu. 
Each time you edit and save the file, a copy is saved so that you can replace the current file 
with a previous edit or even restore a deleted file. You can also compare the contents of all 
the local edits. You can also “Apply Patch(es)” after selecting “Team” in the context menu. 
Select the resource (clipboard, file, URL or workspace) where the patch was generated in the 
“Patch Input Specification” dialog. This resource should contain the same file revisions as the 
line-up on which the patch was generated. For more information, please see the Eclipse 
documentation http://www.eclipse.org/documentation/ 

Preferences 

You can edit XML Editor-relevant preferences by right-clicking in the Source View editor and 
selecting “Preferences”. The following preferences can be edited: 

 Highlighting of the syntax elements: Expand the tree “XML > XML Files > Editor” on 
the left of the dialog box “Preferences” and select “Syntax Coloring”. 

 Hover Help: Expand the tree “General > Editors” to the left of the dialog box 
“Preferences” and then select “Structured Text Editors”. In the “Structured Text 
Editors” dialog box, select the “Hovers” Tab and tick the requested modifier 
preferences. 

 Content Assist: Expand the tree “XML > XML Files > Editor” on the left of the dialog 
box “Preferences” and select “Content Assist”. There you can choose the appropriate 
settings. 

 Formatting: Expand the tree “XML > XML Files” on the left of the dialog box 
“Preferences” and select “Editor”. In this dialog box you can choose and check the 
respective settings of the formatting function. 

For more information, please see the Eclipse documentation: 

http://www.eclipse.org/documentation/ 

3.1.3.2.2 Context Menu of the Source View 

The context menu of the Source View provides access to most of the view’s features via 
right-click. Using this menu, you can 

http://www.eclipse.org/documentation/
http://www.eclipse.org/documentation/
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 Undo changes and revert the XML document to the last saved state, and save the 
current state 

 Highlight the document or part of the document in the Navigator, Project Explorer, 
Outline View or Properties View by selecting “Show In” 

 Select Cut, Copy and Paste 
 Start Quick Fix 
 Manage comments, format or clean up the source code by selecting “Source” 
 Open the Properties View 
 Use Eclipse’s Subversion options by selecting “Team”, “Compare With” or “Replace 

With” 
 Associate an Adaptor 
 Copy an URI or URI fragment, delete the document, show or reload metadata, and 

show Revisions and CRUD warnings that inform you about database problems 
 Select editor-relevant preferences 
 Look up a word in the dictionaries 

With the context menu it is also possible to interact with other modules of the TextGridLab. 
By default, this is true for the Dictionary Search. It is also possible for the Lemmatizer, LEXUS, 
Cosmas II, ANNEX and SADE, if they have been installed. 

3.1.3.3 WYSIWYM View 

The WYSIWYM (=“What You See Is What You Mean”) Editing View provides a word 
processor-like interface and hides the raw XML tags from the user. It uses the TEI schema 
and a standard CSS stylesheet to define the document layout. 

To edit other XML formats or define a custom layout you can use your own schema and CSS 
stylesheet. Your stylesheet should declare paragraph-type elements as “display:block”. 

If your document was not recognized as a TEI document, and no stylesheet association was 
found, you have the option to associate a stylesheet before proceeding. Use the Import Tool 
to import a CSS first or to proceed without associating a style sheet (not recommended). 
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3.1.3.3.1 Features of the WYSIWYM View 

Block and Inline Markers 

In the default setting, no tags are displayed in the WYSIWYM Editing View. To display the 

Block Markers, which mark nested divisions of an XML file, select  in the main toolbar. To 

display the Inline Markers, which mark the single elements of an XML document, select  in 
the main toolbar. 

 

Insert Elements 

You can insert new elements by right-clicking at a selected position in the editor and 

selecting “Insert Element” (or alternatively you can select “XML > Insert Elements”  in the 
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menu bar). Activating the “Show Inline Markers” button on the toolbar is recommended. If 
text is highlighted in the editor when selecting “Insert Element(s)”, the new element will 
surround the highlighted text fragment. In both cases after selecting ’Insert Element(s)’ a list 
of suggested elements allowed at this position will appear. You can use the Up ↑ and Down 
↓ keys on your keyboard to select an element and press “return” to insert it or double-click 
on an element in the list. To insert an element not provided in the proposal list, enter the 
name of the element in the editing field and click “Insert New”. 

3.1.3.3.2 Context Menu of the WYSIWYM View 

The context menu in the WYSIWYM View is similar to that in the Source View. However, 
some options are only found here: for example, adding elements to the WYSIWYM View. 
With the context menu it is also possible to interact with other modules of the TextGridLab. 
By default, this is true for the Dictionary Search. It is also possible for the Lemmatizer, LEXUS, 
Cosmas II, ANNEX und SADE, if they have been installed. 

3.1.3.4 Preview 

If you treat an XML Object with an adequate XSLT document, the Preview will show the 
HTML resulting from this operation. The context menu is the same as in your operating 
system. 

3.1.4 Outline View 

The Outline View facilitates navigation in large XML documents, providing an overview of the 
tree-structure of the document. 

 

3.1.4.1 Title Bar of the Outline View 

By clicking , you can collapse the nodes in the Outline View. Clicking the white downward 
triangle will open the view menu. It offers three operations: “Filters”, “Link with Editor”, and 
“Show Attributes”. Use the two remaining icons to minimize and to maximize the view. 
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3.1.4.2 Context Menu of the Outline View 

The context menu in the Outline View allows you to 

 Associate an Adaptor  

 Copy an URI or an URI fragment   

 Delete , show metadata (  and ), Revisions and CRUD warnings  
 Publish to SADE 
 Carry out the operations that can be performed with the context menu of the Design 

View. 

3.1.5 Properties View 

The Properties View shows in two columns the attributes and the corresponding values. You 
can edit values by selecting an element in the Design, Source, or WYSIWYM Editing View or 
the Outline View and typing directly in the appropriate text field in the value column. Press 
“Enter” to confirm changes made to the attributes. It is recommended that you edit 
attributes in the Properties View when working in the WYSIWYM View, as attributes will not 
be displayed in the WYSIWYM Editing View. 

 

3.1.5.1 Title Bar of the Properties View 

The Title Bar of the Properties View offers you several icons to perform a range of 
operations: 

 Click  to pin this Property View to the current selection. 

 Click   to show categories like “Attributes” in the view. 

 Click  to show advanced properties. 

 Click  to restore the default value. 

 Click  to remove the selected property. 
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 Click the white triangle to open the view menu. The view menu allows you to 
o open a new Properties View 
o pin a property to a selection 
o show categories and advanced properties 
o remove a selected property 
o define the width of the two columns “Property” and “Value” after clicking 

“Configure Columns...” 

 Click the both remaining icons to minimize and maximize the view. 

3.1.5.2 Context Menu of the Properties View 

The context menu in the Properties View allows you to copy and to restore the value of a 
given property. If an element of the Outline View is selected and you then click in the text 
field of the Properties View’s value column, the context menu is the same as in your 
operating system. 

3.1.6 Using the XML Editor 

Some of the main operations for which the XML Editor is intended are explained in the 
following sections. 

3.1.6.1 Open XML Documents 

To open XML documents from the Repository in the XML Editor, either double-click the 
document in the Navigator or right-click on the document in the Navigator and select 
“Open”. Another possibility is to select the XML document in the Navigator and then use the 
menu bar to select “File > Open Object”. To open XML documents from your local system in 
the XML Editor, click “File > Open Local File” and choose the document you want to open 
from the “Open File” dialog of your local system. 

Once a document or file is opened, 

 the Metadata Editor shows the metadata related to the document, 
 in the Editor Field the document content is shown in XML language, 
 in the separated Outline View on the right, the document is represented as a tree or 

hierarchic structure 
 if you click on an element in the XML Editor Field or the Outline View, its attributes 

and their values are then listed in a table within the Properties View. 

At the bottom of the Editor Field in the center you can choose between three different 
editing views of the document: Design View, Source View and WYSIWYM View. The Design 
View shows only the hierarchic structure of the document. The Source View shows the 
document in the XML language. It allows you to access its structure and modify it. The 
WYSIWYM View (= ”What You See Is What You Mean” View) shows the final display and 
format of the content for the web. You can switch between the editing views by clicking on 
the tabs at the bottom of the Editor Field. 
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3.1.6.2 Create XML Documents 

You can create a new XML document either by selecting “File > New Object” in the menu bar 
or via right-clicking a Project in the Navigator and selecting “New Object”. In the opening 
dialog box “New TextGrid Object”, select a target Project and the document type (XML 
document, XML schema, or XSLT stylesheet). Click “Next” and assign metadata in the 
metadata form. Metadata can also be added later. You can click “Next” to associate a 
schema with your XML document or click “Finish” to leave the dialog box. To save changes in 

the document, click “File > Save”, use the in the toolbar, or right-click in the XML Editor 
field and select “Save”. 

3.1.6.3 Associate an XML Schema and Validating XML Files 

It is possible to associate a schema with your XML document not only during the creation 
process of an XML document but also while working in the Source View. Please click “XML > 
Associate a Schema” in the menu bar on top and choose one of the schemas listed in the 
“Select Schema” dialog box. Click “OK” to associate the schema. For associating a schema, 
you can choose between schemas that are located in projects you have access to in the 
Repository or schemas from the built-in XML catalog. To import your own schema to the 
Repository, see Import. Currently only W3C Schemas are supported in the TextGridLab. 

In the Source View, errors in the general XML syntax (such as missing quotes, missing 
brackets, or missing end tags) are indicated as well as validation errors (if a schema is 
specified) with red wavy underlining. To check if your XML document is well-formed and 
valid, you can validate it in any View by clicking “XML > Show Validation Errors” in the menu 
bar on top. The Validation Errors View will pop up below the Editor View showing an error 
message and identifying the invalid XML, if there is an error. 

3.1.7 Interaction of the XML Editor with Other Components 

The Navigator is used for opening and organizing Projects and Objects. Clicking on XML Items 
will open them by default in the XML Editor. 

The Metadata Editor is used for organizing the metadata of Projects and Objects. For 
searching XML documents this information is helpful. The Metadata Editor is able to produce 
a TEI Header from the metadata that can be copied into your XML source code. 

The Unicode Character Table View can be used to insert Unicode signs into an XML 
document. 

The Text Image Link Editor allows you to combine images and texts. The text must be in XML 
and the XML Editor is used by default. 

With the context menu it is also possible to interact with other modules of the TextGridLab. 
By default, this is true for the Dictionary Search. It is also possible for Lemmatizer, LEXUS, 
Cosmas II, ANNEX and SADE, if they have been installed. 
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3.2 oXygen 

oXygen can be installed into the TextGrid Laboratory by downloading the plugin from the 
Marketplace. oXygen is an extern tool. A licence is necessary to use it. For more information 
about oXygen, please see 

http://www.oxygenxml.com/doc/ug-editor/ 

3.2.1 Install oXygen 

To install the oXygen XML Editor, use the Marketplace. 

3.2.2 Open oXygen 

The oXygen XML Editor can be opened by right-clicking an Object and select oXygen. If 
oXygen is set as default, double-clicking on the Object will have the same effect. 

3.2.3 The oXygen XML Editor 

The oXygen XML Editor is described in detail on 

http://www.oxygenxml.com/doc/ug-editor/ 

If oXygen is open inside TextGrid, this will affect the menu bar and the toolbar of the 
TextGridLab. 

3.2.3.1 Menu Bar of the oXygen XML Editor 

If the oXygen XML Editor is open, there will be a second “XML” option in the menu bar of the 
TextGridLab that corresponds to the features in from oXygen. In “Tools > Show Views > 
Others” there are also components of oXygen that can be opened by double-clicking. For 
more information about the oXygen XML menu and the components of the editor, please 
see 

http://www.oxygenxml.com/doc/ug-editor/ 

3.2.3.2 Toolbar of the oXygen XML Editor 

If the oXygen XML Editor is open, elements for the toolbar of this editor will be added to the 
TextGridLab toolbar. For example, they can be used for validation and transformation. More 
details can be found on 

http://www.oxygenxml.com/doc/ug-editor/ 

http://www.oxygenxml.com/doc/ug-editor/
http://www.oxygenxml.com/doc/ug-editor/
http://www.oxygenxml.com/doc/ug-editor/
http://www.oxygenxml.com/doc/ug-editor/
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3.2.3.3 Context Menu of the oXygen XML Editor 

If the oXygen XML Editor is open, the context menu of the TextGrid XML Editor will be 
replenished with elements from the context menu of the oXygen Editor. For more 
information about this element, please see 

http://www.oxygenxml.com/doc/ug-editor/ 

3.2.4 Using oXygen 

For more information about working with the oXygen XML Editor, please see 

http://www.oxygenxml.com/doc/ug-editor/ 

The oXygen XML Editor can be used as an alternative to the TextGrid XML Editor. 

3.2.5 Interaction of oXygen with Other Components 

The oXygen XML Editor interacts with many TextGridLab components in a way similar to that 
of the XML Editor. By using the context menu of the oXygen XML Editor, the Lemmatizer, 
and the publish tool SADE, if installed, can be used. In contrast to the TextGrid XML Editor, 
the Dictionary Search, LEXUS, Cosmas II and ANNEX cannot be used with the oXygen XML 
Editor. 

http://www.oxygenxml.com/doc/ug-editor/
http://www.oxygenxml.com/doc/ug-editor/
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3.3 Text Image Link Editor 

The Text Image Link Editor can be used to link text segments to image sections within 
TextGridLab. A typical application is to link a facsimile and transcriptions, but these texts can 
also be created during the linking process, which allows the use of further tools such as 
image annotations. 

XML texts and images can be opened in their corresponding views. The corresponding 
components are then marked by pairs and the linkage is confirmed. The results can be saved 

as a new Object, the Text Image Link Object , which contains the link information (the text 
and image coordinates, path of XML used and image Objects). Once an Object is saved, 
double-clicking it will reload XML texts, images, and links to continue editing. 

3.3.1 Open the Text Image Link Editor 

The Text Image Link Editor can be started 

 by clicking its icon on the initial Welcome Screen, or 
 as a tool from the menu bar in the TextGridLab, or 

 by clicking its icon  in the toolbar. 

3.3.2 Text Image Link Editor Perspective 

The editor contains the Navigator on the left whose context menu allows you to open 
images or texts - depending on the user rights in particular. On the right-hand are two views, 
one above the other, which are blank if no image or text is selected. As soon as an image is 
opened, it can be seen in the Image View, which is the upper view on the right side. You will 
also automatically see the Thumb View below the Navigator and the detached Toolkit. As 
soon as an XML document has been opened, it will be visible in the XML Editor below the 
Image View. In summary, this perspective consists of an Image View to see the facsimile and 
its selections, the XML Editor field to see its transcription, a Thumb View, and a Toolkit in 
addition to the generic Navigator: 

 Image View shows the image or an image detail to be linked and enables the marking 
of image segments 

 Thumb View shows a reduced version of the entire image and the active image detail 
which can easily be moved and zoomed and that is enlarged in the Image View 

 XML Editor View allows you to open or create texts as well as to mark text parts and 
link them to the image 

 Toolkit provides functions to work in the Image View 
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3.3.2.1 Menu Bar of the Text Image Link Editor Perspective 

If the Image View is activated, the options “Undo”  and “Redo”  can be used under 
“Edit” in the menu bar. If the XML Editor is open in the background, all functions under this 
menu item will be enabled. 

3.3.2.2 Toolbar of the Text Image Link Editor Perspective 

If the Image View is activated, additional elements in the toolbar are usable: 

 Click  to delete active selections 

 Click  to reset the Text Image Link Editor 

If a file has also been opened in the XML Editor, more buttons in the toolbar will be 
activated: 

  links a selected text segment to a selected shape 

  unlinks selected link(s) 

 (next to the linking icons) saves the Text Image Link Object 

  saves the Text Image Link Object as... 

  saves the Text Image Link Object as new Revision 
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3.3.3 Image View 

The Image View is the TextGridLab workspace for editing images. Some of its functions are 
also used for connecting image and text elements. 

3.3.3.1 Features of the Image View 

For editing images, the Image View provides you with several functionalities: selections, 
docking lines, writing mode, rotation function and the Layer Editor. Most are accessible via 
the context menu by right-clicking. 

Selections 

A main feature of the Image View is creating and handling different selections of an image. 
You can create two kinds of shape (rectangles and polygons) to select areas of a picture. A 
shape which is not yet linked to a text sequence is displayed with a dashed outline or frame. 
A solid line marks shapes in the image which are already linked with text sequences in the 
XML Editor View. An existing shape can be selected or activated by double-clicking it. Then 
its border will change its color. You can choose more than one selection by double-clicking 
the created shapes while pressing the [Ctrl] key. 

Docking Line Settings 

You can set docking lines as an optical help after selecting the docking line mode in the 
Toolkit. After a new docking line has been drawn, it can be aligned horizontally or vertically 
by [Shift+H] or [Shift+V] or via the context menu. Click [Ctrl+V] to duplicate a docking line. 
The appearance of docking lines can be modified by using the “Docking Line Settings”: 

1. Right-click in the Image View. 
2. Select “Docking Lines”. 
3. Select “Settings”. 
4. You can choose various line styles: Dot, Solid, Dash, DashDot, DashDotDot. 
5. There are five grades of line width for docking lines. The larger the number, the 

thicker the line. 
6. The line spacing between cloned docking lines can be defined by selecting a new 

value between “10” and “150”. 

The colors of active and inactive docking lines can also be selected by clicking on the two 
colored squares in the “Docking Line Settings” dialog box. After clicking on the squares, a 
palette will pop up. Use the arrow to change the colors of active and inactive docking lines. 
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Writing Mode 

In “Writing Mode”, you can add information about the text direction to the selected sections 
on an image. Use [Shift+S]  to show or hide the writing mode of a selected shape. The writing 
mode for the active selection(s) or for the active document can be changed by right-clicking 
in the Image View. The following options can be chosen: 

 none: this is the default value 
 lr: from left to right 
 lr-tb: from left to right and from top to bottom 
 rl: from right to left 
 rl-tb: from right to left and from top to bottom 
 tb: from top to bottom 
 tb-rl: from top to bottom and from right to left 

If you want to set the writing mode for the whole document, then select “Writing Mode > 
Set writing mode for active document” before creating the shapes. This will change the 
writing mode for all selections which do not yet have a writing mode. All shapes created 
afterwards will use this value. If you want to set the writing mode for a selected shape only, 
please choose “Writing Mode > Set writing mode for active selection(s)”. 

Set Rotation Angle 

There are two ways to rotate a rectangular shape around its middle axis: Via a dialog box or 
around a virtual axis by moving the mouse. The “Set Rotation Angle” dialog can only be 
opened  when a shape is selected by 

 right-clicking in the Image View, selecting “Shape rotation” and “Set Shape rotation 
for active selection(s)” 

 clicking the box with information about the rotation angle in the status bar of the 
Image View. The default setting is 0°. Via context menu or [Shift+P] you can show or 
hide the rotation angle in the status bar of the Image View. 
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The angle can be set via the scrollbar. You can also rotate selected rectangle shapes with 
your mouse via the context menu under “Shape rotation > Activate/Deactivate Shape 
rotation mode” or by the shortcut [Shift+R]. 

The Layer Editor 

It is possible to create logical groups of links (e.g. verses, comments) using the Layer Editor. 
By clicking the box with information about layers in the status bar at the far right of the 
Image View, you can open the Layer Editor. Alternatively, you can select “Text Layers” and 
“Edit Layers” from the context menu in the Image View. 
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In the upper part of the editor, all existing layers are listed. In the lower part of the editor, 
new layers can be created. To create a new layer, click “New/Assume”. The layer 
automatically receives a number. Click in the “Name” text field to add the name of the layer. 
By clicking “Color”, a palette opens from which a color can be chosen. By default, this layer is 
visible. Tick the second box to activate the layer. Only one layer can be active at any time. To 
delete a layer, click the “Remove” button. You can hide or show layers via the title bar of the 
Image View. Press [Shift+L] to show all layers. 

 

3.3.3.2 Menu Bar of the Image View 

If the Image View is open, the operations “Undo”  and “Redo”  in the item “Edit” of the 
menu bar are activated. If the XML Editor is opened and focused, all other operations of that 
menu item will also be enabled. 

3.3.3.3 Title Bar of the Image View 

The * symbol in the title bar of the Image View means that changes are not saved yet. There 
are several buttons in the title bar of the Image View: 

  Show all Layers (if there are layers that were previously invisible) 

  Show Layers 

  Hide Layers 

  Open or Close the Toolkit 
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3.3.3.4 Status Bar of the Image View 

The Image View status bar displays information on (from left to right) 

 the activated mode 
 the content type or Object format of the open image 
 the name of the opened Text Image Link Object 
 a warning signal  if there are still unlinked shapes/selections 
 the rotation angle of the selected shape that can be changed in the “Set Rotation 

Angle” dialog after clicking this field. 
 the coordinates of the mouse pointer in the Image View 
 enabled or activated Layers. The Layer Editor opens after clicking this field 

3.3.3.5 Shortcuts of the Image View 

The following shortcuts are available: 

[Page Up]and [Page Down] Move Image Up or Down 

[+] Zoom In 

[-] Zoom Out 

[0] Zoom Original 

[C] Clone Active Rectangle Horizontally 

[Ctrl+A] Select All Shapes 

[Ctrl+T] Open Or Close the Toolkit 

[Ctrl+V] Clone Active Docking Line 

[Ctrl+Y] Redo 

[Ctrl+Z] Undo 

[Shift + C] Clone Active Rectangle Vertically 

[Shift + H] Horizontal Alignment For Active Docking Line 

[Shift + L] Show All Text Layers 

[Shift + P] Show Or Hide Shape Rotation 

[Shift + S] Show Or Hide Writing Mode 

[Shift + R] Activate Or Deactivate Shape Rotation Mode 

[Shift + V] Vertical Alignment For Active Docking Line 

[Space + Mouse-Left] Move Image 

[Tab] Transverse Between Selections 

3.3.3.6 Context Menu of the Image View 

The Context Menu of the Image View allows several operations: 

 “Link text to selected shape”: connects the selected parts of the image and the text 
 “Unlink selected link(s)”: disconnects the selected link between image and text 
 “Delete active selection(s)”: removes the current selections 
 “Delete all shapes/links”: removes all shapes and all links in an image 
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 “Jump to linked text”: selects the corresponding part in the XML text 
 “Clone (Rectangle) > Clone active rectangle horizontally”: produces a copy of the 

active rectangle to the right.  
 “Clone (Rectangle) > Clone active rectangle vertically”: produces a copy of the active 

rectangle below it 
 “Clone (Rectangle) > Clone active rectangle vertically (upwards)”: produces a copy of 

the active rectangle above it 
 “Clone (Rectangle) > Clone active rectangle horizontally (back)”: produces a copy of 

the active rectangle to the left. 
 “Docking Lines” 

o Alignment of active docking line 
 Horizontal: aligns the active docking line horizontally 
 Vertical: aligns the active docking line vertically 

o Save all lines: saves all docking lines 
o Delete all lines: removes all docking lines 
o Show or hide all lines: shows all docking lines if hidden or vice versa 
o Settings: opens the Docking Line Settings 

 “Writing Mode” 
o Show or hide writing mode: shows writing mode if hidden or vice versa 
o Set writing mode for active selection(s): changes writing mode for selected 

object 
o Set writing mode for active document: changes writing mode for all selections 

which have no writing mode and for new created selections 
 “Shape rotation” 

o Activate or deactivate shape rotation mode for rotating a shape with your 
mouse 

o Show or hide shape rotation mode in the status bar 
o Set shape rotation for active selection(s) via scrollbar 

 “Text Layers” 
o Edit Layers: opens the Layer Editor 
o Edit Layers for selected shapes only: shifts a selection to another layer 
o Show all Layers: all layers will be visible 

 “Image Size” 
o Show original: presents the image in original size 
o Fit Vertically: sets the height of the image to the height of the view 
o Fit Horizontally: sets the width of the image to the width of the view 
o Fit Window: sets the height and the width of the image to the height and the 

width of the view 

3.3.4 XML Editor View 

In order to link images and XML documents, the XML Editor must be open. It is part of the 
Text Image Link Editor perspective by default. 

3.3.5 Thumb View 

The Thumb View opens simultaneously with the Image View. It consists of a a slide control 
bar to adjust the zoom factor in Image View and a selection frame to navigate the active 
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detail in Image View by using the mouse. Click on the part of the image on which you want 
to focus. 

 

3.3.6 Toolkit 

The Toolkit can be opened and closed via the wrench icon in the title bar of the Image View. 
All functions of the Toolkit apply to the Image View. 

 Magnifier  : click and drag to enlarge the selected screen area temporarily (the 
range can be modified with the Ctrl key) 

 Magnifier  : clicking the desktop zooms in and centers the workspace at the 
selected position 

 Magnifier  : zooms out 

 The sliding tool   allows you to move the workspace 

 Rectangular Selection  : click and drag to select a rectangular area 

 Polygonal Selection  : click and drag to create a Polygon. Its outline can be 
completed by double clicking 

  changes to Docking Line Mode 

 “Choose color”: modifies the foreground (= selected, active marking) or background 
(= inactive marking) color of the Shape Selections. Both can be modified by clicking 
the big colored squares 

 “Swap colors” : interchanges the foreground and background colors 

 “Reset color”: clicking the smaller pair of squares resets foreground and background 
color to the default colors (black and white) 

 Raster  : activates the line raster in the Image View to facilitate the alignment of 
the marking 



 
91 3 General Object Editing 

 

3.3.7 Using the Text Image Link Editor 

The following chapter describes the linking of images and texts with the Text Image Link 
Editor. 

3.3.7.1 Open Image and Text 

Double-clicking XML and image Objects in the Navigator opens the XML document in the 
XML Editor and the image in the Image View. Alternatively, XML documents can be opened 
by selecting “Add to Text Image Link Editor” in the context menu of the Navigator. 

3.3.7.2 Select Workspace 

The displayed detail can be selected with the selection rectangle in the Thumb View and the 
scrollbars. The zoom factor can be changed using the slide control in the Thumb View or the 
magnifier tools. 

3.3.7.3 Create Selections in the Image 

First, a part of the image must be selected. Any word, area, or sequence in the image can be 
selected in rectangular (default) or polygonal mode. In rectangular mode, clicking the image 
at one corner of the area to select will draw the rectangular selection if the left mouse 
button is pressed. In polygonal mode, a shape can be drawn by clicking and dragging. 
Releasing the left mouse button places the next corner of the polygon which can be 
completed by double clicking. A shape which is not yet linked to a text is displayed with a 
dashed frame. 

3.3.7.4 Create Links between Text and Image 

Follow these steps to create links: 

1. Select the shape you have created in the image by double-clicking it. 
2. Select text in the XML Editor View by clicking and dragging or by double-clicking (if 

the link is to a single word), triple-clicking (if the link is to a whole line), or with one 
click on the XML tag to select the entire XML element. Text and image sections do 
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not have to be linked immediately. It is also possible to create a large quantity of 
image sections and then link them at a later stage. 

3. Create a link by using the symbol  in the toolbar. After a link between image 
selection and text sequence has been established, the polygonal or rectangular shape 
in the Image View which has been linked will be displayed with a solid line. 

4. Save the result as a new Object , which contains the link information (the text and 

image coordinates, path of XML used, and image files). You can use the  button 

next to  to save this new Text Image Link Object. Once a file is saved, double-
clicking it will reload the XML texts, images and links to continue editing. 

 

3.3.7.5 Correct and Delete Links between Text and Image 

Links can be corrected or deleted later. 

 In the Image View, linked shapes are displayed with a solid line. 
 A link can be selected by double-clicking the shape in the image or the anchor in the 

text field. 
 You can also correct shapes in the Image View. When moving over an active shape, 

the cursor and its icon change: In the center it will become a four way arrow that 
allows you to change the position of the shape by clicking and dragging. Close to the 
boundaries, it will allow you to reposition the edges (with a two-way arrow) or the 
corners (with a diagonal two-way arrow) in a similar way. Polygon changes can be 
performed in a similar manner, with the exception that single edges of polygons can 
not be moved and adjusted. 
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 Linked Objects (i.e. shapes in text and image and their link) can be removed by right 

clicking using the context menu “Unlink selected link(s)” or by clicking the  button 
in the toolbar. 

3.3.7.6 Open and Edit a Text Image Link Object 

To open an new linked Object in the Navigator, right-click it and select ”Open” or double 
click it with the left mouse button. You can also edit a Text Image Link Object via right-click > 
“Edit” in the Navigator. A new editor will open. It shows two columns which are named 
“References in the Object” on the left and “Replace with” on the right. The left column lists 
the image and XML document which are component parts of the Text Image Link Object. 
With the buttons in the category “Add new Object(s)” on the right side you can add new 
Objects or local files to the right column. These Objects will replace the old ones in the left-
hand column. You can also remove Objects from the lists of both columns with the button 
“Remove selected Object”. The position of a selected Object in the list can be changed via 
“Up” and “Down”. All changes made to the Text Image Link Object can be applied by clicking 
on “Apply changes...”. 

3.3.8 Interaction of the Text Image Link Editor with Other Components 

The Text Image Link Editor interacts primarily with the XML Editor, but it can also interact 
with the Navigator and the Metadata Editor. 

As described above, texts, images and Text Image Link Objects can be opened in the 
Navigator. 

The Metadata Editor is used to edit and save metadata for TextGrid Objects. Images as well 
as Text Image Link Objects must be associated with metadata to be searchable. 

The XML Editor is by default a part of the Text Image Link Editor Perspective. 
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3.4 Unicode Character Table 

The Unicode Character Table enables the user to search, to copy, and to insert symbols from 
the Unicode character set into the active editor or the system clipboard. Users can create 
their own custom sets of Unicode symbols for use in the Unicode Character Table. 

3.4.1 Open the Unicode Character Table 

The Unicode Character Table starts automatically as part of the default XML Editor 
Perspective. Additionally, it can be opened in one of the following ways: 

 click  in the toolbar. 
 follow the path “Tools > Show View > Unicode Character Table” in the menu bar. 

The Unicode Character Table also starts automatically together with the XML Editor and can 
be found as a hidden tab behind the Navigator on the left side. 

3.4.2 Unicode Character Table View 

The Unicode Character Table consists of a toolbar and a text box in the header, a table in the 
body, and an information field with function buttons in the footer. 
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3.4.3 Toolbar and Header of the Unicode Character Table View 

The toolbar in the header offers a selection range of all Unicode symbols sorted by 
association to blocks or scripts. By default, Unicode arranges groups of characters together 
in blocks. A script in Unicode is a collection of written signs used to represent textual 
information in one or more writing systems. For more information, please see 

http://unicode.org/ 

For selecting the block range, press the button  for the “Toggle Block Mode” in the toolbar 
and choose the intended entry in the combo box on the right-hand side of the toolbar. To 

select the script sector, press the “Toggle Script Mode” button . If Windows XP is installed 
as your operating system, there may be problems with displaying the symbols. 

To jump to a symbol at a known Unicode point, enter the code point into the textbox. Then 
press “Enter”. As an additional feature, the user can enter a Unicode symbol into the textbox 
and the view will jump to its code point, which is helpful for identifying a symbol or accessing 
additional information on it. 

Use  for mathematical symbols and  for musical symbols. After you have opened the 
view menu of the Unicode Character Table View (using the white downward pointing 
triangle on the right), you can open the mathematical and musical symbols from a pull down 
menu. From here you can also initialize the “Custom Charset Editor” for creating and 
modifying user-defined character sets. 

3.4.4 The Body of the Unicode Character Table View 

The table in the body displays all symbols contained in the selected character set in boxes 
and enables the user to select any of them with a single mouse click. If Windows XP is 
installed as your operating system, there may be problems with the display and insertion of 
the symbols. Using a right mouse click on the selected symbol will open a context menu for 
copying the selected character into the operating system’s clipboard. 

3.4.5 The Information Field of the Unicode Character Table View 

The information field at the bottom of the view shows the Unicode code point as well as the 
description text of the currently selected symbol and displays a magnified view of the 
selected symbol for a more detailed view. The “Insert” button on the right-hand side inserts 
the selected symbol into an open XML Editor document.The Information Field of the 
Unicode Character Table View. 

3.4.6 Custom Charset Editor 

This editor shows a list of currently existing character sets in the head area. The body 
contains a toolbar for inserting, deleting and saving the character sets. The footer displays 
the values of the currently selected character set and allows it to be modified using the 
following options: 

http://unicode.org/
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 Click the  button  to create a new set. 

 To remove a set click   or right-click the set to remove it from the list. 

 Use the   to refresh the list. 
 Furthermore you can save the set outside TextGrid and import external sets by 

clicking  or . 

The name and icon of the character set can be changed as well as the content, which 
consists of either a predefined Unicode blockset or a custom list of Unicode characters. 
These characters can be entered as a decimal Unicode character code point (e.g. “56789”), 
as a Unicode hexadecimal code point with a leading sign (e.g. “U+1D100”), or as a directly 
inserted symbol from the system clipboard. The selected signs must be separated by 
semicolons. Click “Close” to save the charset. 

 

3.4.7 Using the Unicode Character Table 

A typical case for using the Unicode Character Table would be to insert special characters, 
e.g. Σ (u+2211) in an XML document. One example of how to insert a Unicode character “Σ” 
into an XML document is described below: 

1. Open the XML Editor Perspective in the TextGridLab. 
2. Double-click the selected XML document in the Navigator to open it. 
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3. Click or double-click the hidden tab “Unicode Character Table” next to the Navigator 
and Metadata Editor to open the Unicode Character Table View. 

4. Place the mouse pointer in the XML document where the special character is needed. 
5. Select Σ from the table with mathematical operators and click “Insert”. 
6. Σ will be added to the XML document. 

3.4.8 Interaction of the Unicode Character Table View with Other Components 

The Unicode Character Table View is automatically opened when executing the XML Editor. 
In this manner symbols can be included in an XML text without opening a new view.  
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3.5 Workflow Tool 

The Workflow Tool enables the automatic processing of data. A workflow is composed of 
Web Services which take data such as images, XML documents, or plain text as their input 
data and process them. The Workflow Editor ensures that TG-crud will be called to read 
these data from TextGridRep and supply them to the Web Service. At the end of a workflow, 
TG-crud creates new TextGridObjects in the TextGridRep from the output data of the Web 
Services. 

Web Services available in the Internet can be made available for workflows by writing a 
Service Description for them. Service descriptions are created via the File->New dialogue and 
can be treated in the XML Editor. Currently, there are Service Descriptions available for the 
following services:  

 OCR for Fraktur (blackletter) and modern typeface 
 Named Entity Recognition (NER).  

Services can be composed into a workflow by using the Workflow Creation wizard. The 
wizard can create new workflows (use the button “New...” in the Workflow Selection View) 
or modify existing workflows (use button “Edit...” after selecting a workflow from the list in 
that view). Complete workflows including configuration data are saved in TextGrid WorkFlow 
format (TGWF, Mime-Type text/tg.workflow+xml). 

3.5.1 Open the Workflow Tool 

The Workflow Perspective can be opened in two different ways: 

1. By selecting “Workflow” from the “Tools” menu. 

2. By clicking the respective icon  in the toolbar. 

In addition to the Workflow Editor, the Search Results View will open. 

3.5.2 Workflow Tool Perspective 

The graphical user interface (GUI), implemented as an Eclipse perspective, contains an editor 
for the workflow documents with the “Input Documents for Workflow” View at the top left, 
the Workflow Selection View at the bottom left, a Job Management View at the bottom on 
the right, and a Workflow Results View at the top on the right. 

3.5.3 “Input Documents for Workflow” View 

In the “Input Documents for Workflow” View, you can select a TextGrid Workflow (tgwf) 
Object and add it to a workflow. The related TextGrid Objects will be displayed. Before you 
have created or selected a new workflow, this View will be empty. 

After you have preselected a workflow in the Workflow Selection View, the “Input 
Documents for Workflow” View will change to show two columns with lines listed. Drag 
Objects from the Navigator or the Search Results View and drop them into the list of the 
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“Input Documents for Workflow” View. Use the button below the list to remove selected 
documents. If you right-click a document in the list, the context menu will be similar to the 
context menu in the Navigator. 

Depending on the workflow used, there can be more than one input fields (boxes) in the 
view. The type of input fields, as defined in the Service Description used, can be one of the 
following two options: 

 one by one: Documents in this box are processed in a queue and “consumed” in the 
order given until the last document has been processed. If there are more one-by-
one boxes, they must contain the same number of documents, and are processed in 
parallel: first (box A document 1) and (box B document 1), then (box A document 2) 
and (box B document 2), and so on. 

 pooled: Documents in this box will be processed all together in one service call. 
Example of a one-by-one box A and a pooled box B: first (box A document 1) and (box 
B documents 1,2,3,4), then (box A document 2) and (box B documents 1,2,3,4), and 
so on. Note that all documents in a pooled box will not be “consumed”, but rather 
they are available for the next round. 

 

3.5.4 Workflow Selection View 

Here the user can choose the target Project in which the resulting Objects will be created 
and initiate the execution of the workflow. The Workflow Selection View consists of a list of 
workflows, a drop down menu for selecting the target Project and a set of buttons. If you 
right-click a workflow in the list, the context menu will be similar to the context menu in the 
Navigator. 

If no workflow has been added to the list, a new one can be created by using the “New …” 
button. A new dialog will open. Use the “Edit …” button to change a selected workflow. A 
dialog will open that is identical to the one for creating a new workflow. Use “Refresh” to 
update the list of workflows. 
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If a workflow is selected, a target Project must be chosen from the drop down menu. Use 
the “Input Documents for Workflow” View to select TextGrid Objects for the workflow. Click 
“Run” to start the workflow. 

 

3.5.5 Job Management View 

Here you can see the status of your running workflow jobs at the engine. The information 
consists of the name of the workflow run, the starting time, and the current status of the run 
(“active”, “completed” or “terminated”). The Job Management View consists of three 
columns and a button below. Use “Abort and Remove” to stop the run of a workflow and to 
remove it from the list in the Job Management View. If the status of the run is “completed”, 
you can select the workflow job by double-clicking. The results of the run are then presented 
in the Workflow Results View. 
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3.5.6 Workflow Results View 

The Workflow Results View displays the list of resulting TextGrid Objects created. If you 
right-click a document in the list, the context menu will be similar to the context menu in the 
Navigator. Select “Open” or “Open With ...” to check the results of the workflow. 

 

3.5.7 Using the Workflow Tool 

This chapter explains how to create and run workflows in general as well as the use of 
approved services like NER and OCR. 

3.5.7.1 Create a Workflow 

1. Open the workflow creation dialog via clicking „New …” in the Workflow Selection 
View. 

2. First, choose one or more services from the list of services by selecting them (Hold 
CTRL while clicking for multiple services).  

o You can choose either only approved services (automatically activated) or 
services from the list of all services you have read permissions for.  

o If you edit an existing workflow or if the wizard has already assigned a 
structure to the workflow, the checkbox “Keep given services” is 
automatically activated in order to keep the user from unintentionally 
resetting the structure. Uncheck this checkbox if you want to use different 
services. Caution: in this case the link structure and other configuration data 
of the workflow is lost. 

3. In the next step, you can order the selected services, duplicate, (i.e. let the service 
run in another instance a second time) or remove them by selecting them and using 
the buttons. 

4. The selected service appears in a service chain with the service description on the 
next window. If possible, an input and output can be selected from a pull-down 
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menu. This is necessary if the workflow consists of more than one step. By clicking 
“Clear Assigned Associations”, these connections can be reset. 

5. Some services offer configuration options. Use the pull-down menus and the buttons 
to change them. 

6. In the window for metadata transformation for every step of the workflow, you can 
defined which input box metadata should be transferred from and which output 
(result) box metadata should be transferred to .  

o If there is more than one choice of input boxes, each output box offers a 
selection via a drop down menu to choose the input box for the metadata. 
Use the “Configure …” button to edit the title and the format of the output 
files. A pop up dialog will open. 

o Use “title.append” and “title.prepend” if the output files should be named 
like the input files with an suffix or prefix. 

o The default XSLT stylesheet also allows for the parameters “format.exact” and 
“title.exact” for a fixed format and title in the metadata. 

o When editing the workflow directly (i.e. without the wizard), a user-
contributed stylesheet can be used instead. 

o Click “Cancel” to remove your changes or “Finish” to save them. 
7. Finally, select a name for the new workflow and the Project in which it should be 

saved. 
8. Use “Finish” to complete this process. 

In the Workflow Selection View, use “New …” to create another workflow or “Edit...” to 
change an existing one. 

3.5.7.2 Run a Workflow 

1. Select an existing workflow from the list in the Workflow Selection View. This 
workflow must have been already created. 

2. Drag and drop an Object from the Navigator or Search Results View into the input 
box of the “Input Documents for Workflow” View (for example image scans in case of 
running the OCR service and XML documents in case of running the NER service). 

3. Select a target Project from the menu in the Workflow Selection View. The result will 
be saved there. 

4. Click „Run”. The progress is documented in the Job Management View. 
5. To stop or remove a job, click “Cancel and Remove”. 
6. The “status” column changes to “completed” as soon as the workflow has finished. 

Double-click the name of the job and the output Objects will be displayed in the 
Workflow Results View. 

7. Select “Open” or “Open With ... > Text Editor/XML Editor” to check the result. 
8. To save the result (e.g. a plain text document) on your local system click “File > Save 

Copy as Local File” in the menu bar. 
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3.5.7.3 Writing a Service Description 

Purpose and Usage 

For TextGrid 2.0, a special XML-based Service Description language has been developed. 
Established service description languages like WSDL or WADL both contain too many details 
and are not sufficient for the purposes of TextGrid. Some points for motivation: 

 WSDL/WADL can contain more than one operation. However, in a workflow setting, 
the service must be launched with a certain operation specified 

 There is no semantic distinction between input data and configuration parameters. 
However, in TextGrid, batch processing on input data and fixed configuration 
parameters are requirements 

 WSDL uses XSD-based types for parameters, however, TextGrid uses a Mime-Type 
based model 

 From a WSDL, a user only knows the type (e.g. “xsd:string”) but not the possible 
values of a parameter (e.g. “UTF-8”). These need to be guessed or documented by 
separate means. However, having some of the possible values in a service description 
makes usage easier 

 English names for input and output parameters and specific configuration values are 
desirable 

 descriptive metadata, information about a license, etc., for a service are desirable 

Additionally, REST-based services might not have any WSDL or WADL description at all. In 
this case, a service description that notes its usage is inevitable. 

This is the usage pattern: 

1. A web service exists and either its developer or another TextGrid developer would 
like to make it available in TextGrid 

2. The developer writes a TextGrid service description for that service. Since there is not 
yet a GUI, an XML or plain text editor should be used. The necessary steps include: 

1. identify descriptive metadata about the service 
2. point to a WSDL service description (soap) or a service endpoint (rest) 
3. identify the service's operation to be used 
4. separate the inputs proper from configuration parameters 
5. give some details about each input, configuration, and output parameter 
6. provide possible example values for the configuration parameters, either 

inline or using a URI pointing to a TextGridObject 
3. The service description will be saved as a TextGridObject document in one of the 

developer's projects 
4. Verify the correctness of the service description by creating a workflow that contains 

it and running this workflow 
5. Once the service proves stable and usable, the description can be published and the 

TextGrid core team can be asked to list it among the approved services 

During the creation of a workflow, many settings of a service description are evaluated by 
the workflow wizard. The TextGridURIs of the service descriptions will be included into the 
TGWF workflow document. They will be retrieved again upon submission of the workflow 
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job, influencing the structure and the data of the Petri Net (GWDL document) that the 
workflow engine accepts. 

Creation 

1. Go to File - New - Element - XML Document. 
2. In the following dialogue, select a project and type “TextGrid Service Description 

(text/tg.servicedescription+xml)”, click “Next”, enter a title, click “Finish”. 
3. The TextGrid XML Editor will open with a service description skeleton 
4. Fill in the skeleton provided. You can use both the XML Editor's Design view and the 

Source view. However, choosing the Source view will allow you to to use the 
documentation annotation of the underlying Schema file which pops up when the 
mouse pointer rests on an XML tag. 

Technical Details 

XSD: The XML Schema file includes documentation annotation and can be found here: 
https://develop.sub.uni-goettingen.de/repos/textgrid/trunk/lab/base/info.textgrid.lab. 
workflow/ resources/ServiceDescription.xsd 

Element Details: In addition to the documentation in the XSD file, more details about the 
contents of a Service Description are listed here. 

 During workflow composition, only data in service/descriptivedata/name, 
service/inputs, service/outputs and service/configparameters are being evaluated 

 During workflow submission, both these data and service/technicaldata are being 
evaluated 

 Since CRUD is returning TextGrid documents Base64-encoded, all input and output 
values MUST be of type xsd:base64Binary 

 service/technicaldata: 
o type: can be currently one of “soap” or “rest” 
o operation:  

 for soap, the name of the desired operation out of the operations as 
listed in the WSDL. 

 for rest, one of GET or POST (currently the only supported operations) 
o descriptionlocation: the “uri” attribute must be filled with  

 for soap, the address of the WSDL. Note: the WSDL must be self-
sufficient, i.e. the workflow engine will address the service endpoint 
listed therein and there is no possibility to pass the engine a different 
endpoint. Both the WSDL and the service location within the WSDL 
must be accessible from the workflow engine. 

 for rest, the invariable service endpoint. It usually has a form such as 
“http://server.example.org/service/operation?”. It can contain 
placeholders marked with an “@” sign for parameters, such as 
“http://example.org/items/@id/show?” 

o targetnamespace: this applies for soap services and describes the target 
namespace of the XML schema associated with the service.  

https://develop.sub.uni-goettingen.de/repos/textgrid/trunk/lab/base/info.textgrid.lab.%20workflow/%20resources/ServiceDescription.xsd
https://develop.sub.uni-goettingen.de/repos/textgrid/trunk/lab/base/info.textgrid.lab.%20workflow/%20resources/ServiceDescription.xsd
http://server.example.org/service/operation
http://example.org/items/@id/show
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 Set the usetns attribute to true to tell the Workflow Engine that the 
message parameters should be prepended with the targetNamespace 
given by the uri attribute. 

 Hint: set usetns to true if the schema definition part in the WSDL has 
elementFormDefault=“qualified”. 

 If you interact with a Web Service written in a namespace-ignorant 
language (such as PHP, Python, Perl, or Tcl), usetns should perhaps be 
false. 

 service/inputs is for the proper input parameters for the service, i.e. the parameters 
that are variable depending upon the actual objects being processed 

o @multiple 
 “false” would mean that the this input took one data block/URI at a 

time and consumed them in a queue. In the GUI, this is called “one by 
one”. 

 “true” means that the service takes possibly many arguments at once, 
as in a collate service. Those arguments will not be consumed by the 
engine and are ready each time the service is being called. In the GUI, 
this is called “pooled” 

 There MUST be at least one input with multiple=“false” such that the 
engine has a finite queue to process. 

o @crud=“true” would mean that the service knew how to read/readmetadata 
from TG-crud and this input param accepted a URI 

o @param is the name of the element / parameter as given in the service 
description document 

o @name is a human-readable string which will be displayed so that users will 
know what this parameter is about 

o @mimetypes are the mime type(s), separated by commas, of the documents 
accepted by this service for this parameter 

o @optional: set to true if this parameter can be omitted 
o for rest, one special input can have the name “POSTBODY”. This will then be 

handed to the server unchanged in the POST call 
 service/outputs are the output parameters from the Service. 

o Every output parameter must produce some result, i.e. there will either be a 
new TextGridObject document if the service is the last one in the workflow 
chain, or must be connected to an input parameter of some service further 
down the chain. 

o @crud=“true” would mean that the service knew how to create a new TGO 
via Crud and this output param returned a URI 

o for the meaning of the rest, see inputs 
 service/configparameters are those input parameters that are constant throughout 

the workflow 
o Each parameter will have some example values which can be used directly or 

serve as a starting point for modification by the user 
o @needsB64encoding=“true” tells the editor to encode the text given by the 

user in Base64 before handing it over to the service 
o for the meaning of the rest, see inputs 
o there MUST be at least one <examplevalue> sub-element for each 

<configparameter> 
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o the list of example values is meant as a hint to the user and not as an 
exclusive list, i.e. it can be extended by users in their workflows 

o Attributes of example values: 
 @id will be used by the workflow editor to remember this value in 

workflow documents 
 @name is a human readable name for display, e.g. “The FooMatic 

value” 
 @default=true if this is the default value for this configuration 

parameter. Please specify EXACTLY ONE default value (this will not be 
checked by the schema) 

 @inline 
 true if the element's content is to be used directly as value 
 false to specify a TextGridObject URI in the element's content 

 Inline parameter values will be written as-is, i.e. as strings. If they are 
XML, please provide some namespace such that they do not inherit 
the servicedescription namespace. 

3.5.7.4 Named Entity Recognition (NER) 

The Named Entity Recognition Service was developed by TEXTvre at King’s College in London 
(http://textvre.cerch.kcl.ac.uk/). This service takes as their input an XML document (typically 
TEI XML) transmitted in binary form and returns the same document with additional XML 
tags for the named entities. It is described in more detail on 

http://textvre.cerch.kcl.ac.uk/?m=201011 

3.5.7.5 Optical Character Recognition (OCR) 

The Optical Character Recognition (OCR) workflows allow you to translate scanned images of 
printed “Fraktur” (blackletter) and “Antiqua” texts into machine-encoded text. The 
results generated will enable you to edit the text in TextGrid, browse it, or to do text mining. 
The OCR service of TextGrid is based on ocropus. The service is optimized for special types of 
fonts and some training maybe needed. For more information, please see 

http://code.google.com/p/ocropus/ 

If there is no Project, a new one must be created. After refreshing the Navigator, the created 
Project will be displayed there and must be selected in order to import images to it. Next, 
open the “File” menu and select “Import local files” to import the images there. After 
refreshing the Navigator again, it will display the imported images. Open the workflow. On 
the right side, the views “Input Document for Workflow”, “Workflow Results”, “Workflow 
Selection” and “Job Management” will appear, which will be relevant during the next steps. 

First a new workflow is needed. It can be created in the Workflow Section. OCRopus Fractur 
or Modern can be chosen as services and afterwards the default values are kept. In the last 
window the workflow can be named and assigned to a specific Project. 

http://textvre.cerch.kcl.ac.uk/
http://textvre.cerch.kcl.ac.uk/?m=201011
http://code.google.com/p/ocropus/
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After refreshing the Workflow Section, the newly created workflow becomes visible. After 
double clicking it, an empty list is displayed in the “Input Document for Workflow” View. The 
images to execute can simply be dragged there from the Project on the left. 

Now, select the workflow in the Workflow Selection View and assign a “Target project”. 
Clicking “Run” will now start the image recognition and while it is running, the status will be 
displayed in the Job Management View. 

After finishing, the result will be displayed in the Workflow Results View and can be opened 
by right-clicking “Open with > Text editor”. 

 

3.5.8 Interaction of the Workflow Editor with Other Components 

To add Objects to workflows, you must drag them from the Navigator or the Search Results 
View. The special workflow Objects (tgwf documents) can be edited in the XML Editor; 
however, usage of the graphical workflow wizard is recommended. 
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4 Subject-specific Tools and Services 

Tools for special research requirements are explained in this part. 
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4.1 Linguistic Tools 

This chapter offers a compilation of tools for textual analysis. With these tools and future 
additions, users can use the TextGridLab to perform research on linguistic and grammatical 
phenomena, such as content analysis, contextual evaluation (the use contexts of vocabulary, 
single phrases, etc.), indexing, annotation, segmentation, and classification of text and word 
units as well as morphological studies. 

4.1.1 Dictionary Search 

The Dictionary Search tool allows users to browse the dictionary network 

http://www.woerterbuchnetz.de 

at the Center for Digital Humanities at the University of Trier. The following dictionaries may 
be browsed: 

 General dictionaries: German Dictionary by Jacob and Wilhelm Grimm; Grammatical-
Critical Dictionary of the High German Dialect by Johann Christoph Adelung 

 Author’s dictionaries: Goethe Dictionary 
 Dialect dictionaries: Dictionary of the Alsatian Dialect by Ernst Martin and Hans 

Lienhart; Dictionary of German-Lorrainese Dialects by Ferdinand Follmann; Dictionary 
of the Palatine Dialect by Ernst Christmann et al.; Rhenish Dictionary; Supplement to 
the Rhenish Dictionary 

 Middle High German dictionaries: Middle High German Dictionary by Matthias Lexer; 
Middle High German Dictionary by Georg Friedrich Benecke, Wilhelm Müller and 
Friedrich Zarncke; Supplement to the Middle High German Dictionary by Matthias 
Lexer 

 Luxembourgian dictionaries: Luxembourgian Dictionary, Dictionary of the 
Luxembourgian colloquial speech; Dictionary of the Luxembourgian dialect 

4.1.1.1 Open the Dictionary Search 

To open the Dictionary Search Perspective 

 choose the Dictionary Tool from the Welcome Screen, or 
 select “Tools” from the menu bar and click “Dictionary Search”, or 

 click the icon  in the toolbar. 

The Dictionary Search Results View, which is part of the Dictionary Search, can also be 
opened separately by 

 selecting “Tools > Dictionary Search” in menu bar, or 

 clicking  in the toolbar. 

http://www.woerterbuchnetz.de/
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4.1.1.2 Dictionary Search Perspective 

The Perspective is subdivided into three views: the Dictionary Search View on the upper left, 
the Dictionary Search Results View on the upper right and the Dictionary Grid View at the 
bottom. 

 

4.1.1.3 Dictionary Search View 

To look up a word, fill in the Dictionary Search mask as follows: 

 Type a keyword in the first input field. The search is not case sensitive. 
 You can limit the number of results displayed. By default, the first 10 results will be 

displayed. 
 Choose between exact or fuzzy search. In fuzzy search, similar strings will also be 

found. 
 Mark the box or boxes of the dictionaries to be searched. 
 To start the search, click the icon “Start Search”. 
 You can use wildcards. The asterisk (*) substitutes any zero or more characters, and 

the question mark (?) substitutes exactly one character. You can combine these 
search methods. 
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4.1.1.4 Dictionary Search Results View 

You see the number of results in the upper right corner of the view. For orientation, the first 
line of the article (up to 13 words of the lemma) is displayed. If the number of results 
exceeds the display limit, you can view the remaining results by clicking the “Next” or the 
“Previous” button. 

4.1.1.5 Dictionary Grid View 

To look up the entry in the dictionary, click the short form listed in the Dictionary Search 
Results View. The entry will open in the Dictionary Grid View. The tabs in the head of the 
Dictionary Grid View lead to further information about the online dictionary and the project 
into which the online dictionary is embedded. The field at the top of the left column is used 
for searching lemmas. This quick view starts with the article in question. It lists the following 
articles as well, depending on their length. You can use all options available in the online 
dictionaries to search in more detail. In this view, the context menu corresponds to the 
context menu of your operating system. 

4.1.1.6 Using Dictionary Search 

To look up a word, fill in the Dictionary Search mask as follows: 

1. Insert a keyword in the first input field of the Dictionary Search View. The search is 
not case sensitive. Alternatively, you can double-click a word in the XML Editor if the 
Dictionary Search in open. 

2. You can limit the number of results displayed. By default, the first 10 results will be 
displayed. 

3. Choose between exact or fuzzy search. In fuzzy search similar strings will also be 
found. 

4. Mark the box or boxes of the dictionaries to be searched. 
5. To start the search, click the icon “Start Search”. 
6. You can use wildcards. The asterisk (*) substitutes any zero or more characters, and 

the question mark (?) substitutes exactly one character. You can combine these 
search methods. 

7. The result is displayed in the Dictionary Search Results View and the selected result in 
the Dictionary Grid View. 

4.1.1.7 Interaction of the Dictionary Search with Other Components 

The functionality of the Dictionary Search tool can also be used while working on an XML 
document. Open the Dictionary Results View. Any word in the XML Source View can be 
looked up via context menu (right-click) > ”Search in Dictionaries”. 

4.1.2 Lemmatizer 

The Lemmatizer enables the user to retrieve the lemma relating to a given German 
wordform as well as to analyze the inflected wordform. The Lemmatizer is based on the 
German computational morphology SMOR 
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http://www.ims.uni-stuttgart.de/projekte/gramotron/PAPERS/LREC04/smor.pdf 

and on morphological lexicon component MORPHISTO: 

http://www1.ids-mannheim.de/lexik/TextGrid/morphisto/ 

4.1.2.1 Install the Lemmatizer 

In order to use the Lemmatizer, you must first Install “Linguistic Tools” from the 
Marketplace. 

4.1.2.2 Open the Lemmatizer 

You can open the Lemmatizer in different ways: 

1. Click “Tools > Show View” in the Menu Bar and select “Lemmatize Wordform” or 
“Lemmatize File”. 

2. “Lemmatize Wordform” can also be opened by clicking on in the toolbar. 
3. If a document is opened in the Source View or the WYSIWYM View of the XML Editor, 

the “Lemmatizer” can be selected in the context menu. 

4.1.2.3 The Lemmatizer Tool 

The Lemmatizer Tool consists of three elements: an input field, a configuration field, and a 
results field. If “Tools > Show View > Lemmatize Wordform” is chosen, the input field is 
dedicated to a German word form. If “Tools > Show View > Lemmatize File” is selected, the 
“BatchLemmatizer” for lemmatizing whole documents will open and you can choose 
between lemmatizing plain ASCII text, a German Wordform List, or tokenized TEI-conform 
XML depending on the format of your document. Click “Specify Input File” to select and 
upload your file from your computer. Make sure you have selected the corresponding file 
format. 

In the configuration field the current form of the analysis is shown. Click “Make (Other) 
Configuration” to change it. A dialog opens in which you can change the output format and 
the lexicon. You can also set various options for the analysis: lemmatization, disambiguation, 
guesser for unknown word forms, fuzzy search, and ZLib Compression. 

After clicking “Start Lemmatizer!”, the results will be displayed in the results field below the 
configuration field. If you wish to save the result of lemmatizing a file, use the “Save Output” 
button at the bottom of the results field. 

4.1.2.4 Using the Lemmatizer 

You can either lemmatize a wordform or a document as a whole. 

Lemmatize a Wordform 

1. Open the Lemmatizer by selecting “Tools > Show View > Lemmatize Wordform” in 

the menu bar, or by clicking the icon  in the toolbar. 

http://www.ims.uni-stuttgart.de/projekte/gramotron/PAPERS/LREC04/smor.pdf
http://www1.ids-mannheim.de/lexik/TextGrid/morphisto/
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2. Enter a wordform. 
3. Choose a configuration. 
4. Click “Start Lemmatize!”. The result will be displayed in the results field below. 

Alternatively, you can open the Lemmatizer via the context menu in the text editor, or in the 
XML Editor (in Source View as well as in WYSIWYM View). 

1. Mark the word and right-click on it. The context menu will open. 
2. Move your mouse over or click on “Lemmatizer”. 
3. Select “Lemmatize Wordform” or “Get analysis”. The result will be displayed in the 

results field below. 

Lemmatize a Document 

1. Open the “BatchLemmatizer” by selecting “Tools > Show View > Lemmatize File” in 
the menu bar. 

2. Specify the input file and the configuration. 
3. Click “Start Lemmatize!” 

4.1.2.5 Interaction of the Lemmatizer with Other Components 

The Lemmatizer can be directly accessed from within the XML Editor and the oXygen XML 
Editor via the context menu. 

4.1.3 LEXUS 

LEXUS provides an environment for the creation of online lexica. Embedded in TextGrid, the 
tool allows you to use lexical resources provided by the Max Planck-Institute for 
Psycholinguistics in Nijmegen and by the Institute for German Language in Mannheim. For 
more information, please see 

http://www.lat-mpi.eu/tools/lexus/ 

and http://www.owid.de/wb/elexiko/start.html. 

4.1.3.1 Install LEXUS 

In order to use LEXUS, you must first Install “Linguistic Tools” from the Marketplace. 

4.1.3.2 Open LEXUS 

You can open LEXUS in different ways: 

1. Click “Tools > Show View” in the menu bar and select “LEXUS”. 

2. Click  in the toolbar. 
3. If a document is opened in the Source View or the WYSIWYM View of the XML Editor, 

“Search in LEXUS” can be selected from the context menu. 

http://www.lat-mpi.eu/tools/lexus/
http://www.owid.de/wb/elexiko/start.html
file:///C:/wiki/display/TextGrid/Source+View
file:///C:/wiki/display/TextGrid/WYSIWYM+View
file:///C:/wiki/display/TextGrid/XML+Editor
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4.1.3.3 LEXUS Tool 

The LEXUS Tool consists of three elements: An input field, a section in which you can set 
various advanced search options, and a results field. Enter a word or phrase in the input field 
and click “Enter” or the “Search” button to start the query. The search is case-sensitive. You 
can also use the drop-down menu at the end of the input field to select a word or phrase for 
which you have searched earlier in this session. 

You can set advanced options after opening the section below the input field by opening the 
line below the search term. A target lexicon can be selected. Currently data from the 
German dictionary elexiko (http://www.owid.de/wb/elexiko/start.html) from the Institute 
for German Language in Mannheim, Germany, is available, as well as a Wichita lexicon 
offered by Max-Plank-Institute for Psycholinguistics (http://www.lat-mpi.eu/tools/lexus/) in 
Nijmegen, the Netherlands. 

The target data categories that can be chosen depend on the structure of the selected 
lexicon. Relating to the target data category, various search conditions can be set: “is”, 
“contains”, “begins with”, and “ends with”. In addition to these options, you can select “is 
negated” via a check box to filter your query. 

The search results are presented in the results field below the options menu. Results of 
different queries are shown in different tabs. On the left side of the result you will find a tree 
of folders according to the structure of the selected lexicon. The lexicon entry itself is 
displayed on the right side. 

 

http://www.owid.de/wb/elexiko/start.html
http://www.lat-mpi.eu/tools/lexus/
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4.1.3.4 Using LEXUS 

1. Open LEXUS by selecting “Tools > Show View > LEXUS” in the menu bar or the  in 
the toolbar. The LEXUS tool opens below the XML Editor. 

2. Enter a word in the input field. You must have selected the appropriate lexicon. 
Currently, the German lexicon is the default setting. 

3. Optionally, you can set advanced search conditions on the target data category. In 
the German lexicon the default category is “lzgA”, which denotes the lemma itself; 
the default search condition is “is”, i.e. only the exact lemma is retrieved from the 
lexicon. 

4. Click “Search” to start browsing the lexicon. 

Alternatively, you can open LEXUS via the context menu of the Source View or the 
WYSIWYM View in the XML Editor. 

1. Mark the word in the XML Editor and right-click on it. The context menu will open. 
2. Click on “Search in LEXUS”. The LEXUS tool will open below the XML Editor, and your 

search will start immediately. The result will be displayed in the results field. 

4.1.3.5 Interaction of LEXUS with Other Components 

A search in LEXUS can be initialized directly within the XML Editor via the context menu of 
the Source View, the WYSIWYM View or the Preview. 

4.1.4 Cosmas II 

“Cosmas” stands for Corpus Search, Management and Analysis System. It is a full-text 
database for linguistically and lexicographically motivated queries in the corpora of the 
Institute for German Language (IDS). Queries can concern German words, word classes, 
word distance and position. Results can be sorted by time, country and topic as well as being 
analysed for usage patterns. The German Reference Corpus (Deutsches Referenzkorpus), 
which can be accessed through COSMAS, consists of about 3 billion words from German 
newspapers, magazines and books of various genres. For more information, please see 

http://www.ids-mannheim.de/cosmas2/ 

At the time of this writing, accessing the corpus from within TextGridLab is restricted to a 
limited amount of texts due to copyright issues. 

4.1.4.1 Install Cosmas II 

In order to use Cosmas II, you must first install “Linguistic Tools” from the Marketplace. 

4.1.4.2 Open Cosmas II 

You can open Cosmas II in different ways: 

1. Click “Tools > Show View” in the menu bar and select it. 

http://www.ids-mannheim.de/cosmas2/
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2. Click  in the toolbar. 
3. If a document is opened in the Source View or the WYSIWYM View of the XML Editor, 

mark any word in the editor, and select “Search in Cosmas II” in the context menu. 

4.1.4.3 Cosmas II Tool 

The Cosmas II Tool consists of two elements: An input field and a results field. Enter a word 
or phrase in the input field and click “Enter” or the “Search” button to start the query, or 
click the downward pointed angle at the end of the input field to open a drop down menu 
and select a word or phrase you have searched for earlier in this session. The search is not 
case-sensitive. 

 

The results are presented in the lower field with its source, a KWIC (Key Word in Context) 
View which shows the searched keyword in the context of the result, and a reference. 
Results of different queries are shown in different tabs. Use the context menu to copy 
selected results to the clipboard, to export them as a CSV file, or to select all results. 

4.1.4.4 Using Cosmas II 

1. Open Cosmas II by selecting “Tools > Show View > Cosmas II” in the menu bar, or the 

 in the toolbar. The Cosmas tool opens below the XML Editor. 
2. Enter a word or phrase in the input field. 
3. Click “Search”. 
4. You can copy the results by right-clicking on them and click “Copy selected results to 

clipboard” or “Export selected results as CSV file” in the context menu. If you have 
copied the results to the clipboard, use “Paste” or “Ctrl+V” to include them in a 
document. 

Alternatively, you can open Cosmas II via the context menu of the Source View or the 
WYSIWYM View in the XML Editor. 
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1. Mark the word in the XML Editor and right-click on it. The context menu will open. 
2. Click on “Search in Cosmas II”. The Cosmas tool will open below the XML Editor, and 

your search will start immediately. The result will be displayed in the results field 
3. For copying or exporting the results, see point 4 above. 

4.1.4.5 Interaction of Cosmas II with Other Components 

Cosmas II can be opened directly within the XML Editor via the context menu of the Source 
View or the WYSIWYM View. 

4.1.5 ANNEX 

ANNEX is a Flash-based tool which allows users to watch video resources in sync with their 
annotations. It uses files created with ELAN (http://www.lat-mpi.eu/tools/elan/). In the 
ANNEX View, users can chose to display one or more of the annotation tiers and in different 
frame set-ups (views). Single segments of a video can be selected and played back. 
Rewinding and forwarding by seconds in a video tape is possible as well. 

4.1.5.1 Install ANNEX 

In order to use ANNEX, you must first Install “Linguistic Tools” from the Marketplace. 

4.1.5.2 Open ANNEX 

You can open ANNEX in two different ways: 

1. Click “Tools > Show View” in the menu bar and select “ANNEX”. 

2. Click  in the toolbar. 

4.1.5.3 The ANNEX Tool 

The ANNEX workspace uses the data from the annotation file. In the upper left corner, the 
media file corresponding to the annotation is displayed through a QuickTime plugin. Further 
to the left is the first control panel with different options such as “Text”, “Grid”, “Subtitle” 
and “Timeline”, plus “Waveform” and “Combined” which are not always present. On the 
right of the video file there is a panel with “Media Information”. The lower part of the page 
is the main data frame. 

http://www.lat-mpi.eu/tools/elan/
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4.1.5.4 Media Player 

Below the media, several controls are displayed, allowing users to adjust the volume, play or 
pause the video, forward, rewind, as well as change the Settings of the buffer time. To the 
right of the video display, media information is presented including resource, media file and 
elapsed time. If a selection of the video has been chosen, then the start and end time of the 
segment will be shown here as well. Both the media player and the information panel can be 
minimized. 

4.1.5.5 Control Panels 

The first control panel, on the left of the video display,usually has four buttons: “Text”, 
“Grid”, “Subtitle”, and “Timeline”. If the object also contains a waveform, two more options 
will be available: “Waveform” and “Combined”. Depending on which data viewing mode is 
activated, the rest of the workspace will change accordingly to display the data in the 
appropriate mode. 
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Text Mode 

This view shows a column for each of the selected tiers. In each column the annotations of a 
tier are displayed in lines. You can click on an annotation to play the corresponding part of 
the media file. When the recording is being displayed, the relevant parts of the annotations 
will be highlighted in red. 

 

Grid Mode 

This view shows all annotations with their start and end times from the tiers selected in the 
media information panel. The annotations are displayed in chronological order. You can click 
on an annotation to play the corresponding part of the media object. As the video 
progresses, the relevant parts are highlighted. In addition, to the left of the grid, you can 
choose the type of tier from a drop down list. 

 

Subtitles Mode 

This view shows the annotations as if they were subtitles while playing the video. 
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Timeline mode 

This view is similar to the timeline viewer in ELAN. It displays the tiers and their annotations, 
and each annotation corresponds to a specific time interval. Above the tiers, a timescale is 
displayed. During playback, a red vertical bar, the crosshair, moves through the annotations 
and indicates the current point in time. Furthermore, whenever you select a time interval, it 
will be marked with a blue rim. The corresponding start time, end time, and duration are 
displayed in the media information panel. 

When you select a specific segment, three more options will become available (see the left 
side of the timeline): 

 Play selection: the video display will play only the selected segment 
 Clear selection: the blue rim will disappear, along with the information about the 

start and end times, etc., that is contained in the media information panel on the 
right of the video display 

 Link to selection: when you select this option, a message will appear informing you 
that the address of the selected segment has been copied to the clipboard 

In addition, to the left of the timeline, there are further options which are unique to the 
Timeline, Waveform, and Combined modes: 



 
121 4 Subject-specific Tools and Services 

>| and |< (Move timeline view to the end/beginning) 

>> and << (Move timeline view forward/backward) 

> and < (Move timeline view slowly forward/backward) 

+ and - (Zoom timeline view in/out) 

The Timeline can also be played in two different modes: 

1. Play screen by screen, in which the crosshair (red vertical bar) will move to the right 
of the screen and change every time or 

2. Play continually, where the crosshair will remain in the center of the screen and the 
annotations in the tiers will move. 

Below these two view modes, there is the option to change the tier text font. Finally, to the 
right of the Media Information Panel, there is another window which allows users to view 
particular tiers in isolation. As the video progresses, the relevant part of the text from the 
selected tier will be highlighted in red. 
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Waveform and Combined 

If there is a waveform in the document, it can be viewed in the Waveform mode. You can 
also combine the waveform and the timeline view modes in one screen with the combined 
mode. 

4.1.5.6 Using ANNEX 

For more information on creating and working with audiovisual documents with ELAN and 
ANNEX, please see 

http://www.lat-mpi.eu/tools/elan/ 

http://www.lat-mpi.eu/tools/annex/ 

4.1.5.7. Interaction of ANNEX with Other Components 

ANNEX can be directly started via the context menu of the XML Editor. 

http://www.lat-mpi.eu/tools/elan/
http://www.lat-mpi.eu/tools/annex/
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4.2 CollateX 

CollateX is a Java software for collating textual sources, for example, to produce a critical 
apparatus. It was developed jointly by several partner institutions and individuals under the 
umbrella of the European initiative “Interedition”. For more information, please see 

http://collatex.sourceforge.net/ 

4.2.1 Install CollateX 

In order to use CollateX, you must first install it from the Marketplace. 

4.2.2 Open CollateX 

CollateX can be opened in different ways: 

1. Choose CollateX from “Tools” on the menu bar. 

2. Click  on the toolbar. 
3. Double-click a collation set or an equivalence set in the Navigator or the Search 

Results View 
4. Right-click a collation set or an equivalence set in the Navigator or the Search Results 

View and select CollateX from the option “Open With...” 

4.2.3 The CollateX Perspective 

The CollateX Perspective consists of two components. The first one lists the collation and 
equivalence sets, and the second shows the results of the collation. 

When CollateX is opened, four new icons will appear on the TextGrid toolbar: 

1.  for creating new collation sets. 

2.  for creating new equivalence sets. 

3.  to collate texts. 

4.  to delete active selections in the equivalence set. 

 

http://collatex.sourceforge.net/
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4.2.4 Collation Set and Equivalence Set Component 

In the upper part of the CollateX Perspective, collation and equivalence sets will be shown by 
default. If these sets are not selected, the upper part will be empty. If you wish to create a 

collation set, you can click on  on the toolbar to open the collation set list and drag and 
drop TextGrid Objects from the Navigator or Search Results View into the list. The collation 
set is the set of all text witnesses the collation should take into account. The texts must be 

given as plain text (.txt). To create an equivalence set, click on  in the toolbar to open the 
equivalence set list and drag and drop tokens from the Collation Result Component into the 
list. The equivalence set defines all items that should be treated as identical. Variance 
between them will be ignored by the tool. 

4.2.5 Collation Result Component 

If a collation has been completed, the result will be displayed in the lower part of the 
CollateX Perspective. This component presents the result in three different ways: 

1. The Alignment Table  shows every element of a text and compares it with the text 
passage in the other texts. Every variance is highlighted. 
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2. The variants are also illustrated in a graph  that can be seen after clicking on the 
second tab of the component. Drag an element with your mouse if you want to move 
it.   

3. The results are also presented in the form of TEI-conformant XML. 

4.2.6 Using CollateX 

CollateX can be used for collating existing text Objects as well as for standardizing the 
readings of the texts. 

4.2.6.1 Collating Texts 

1. In order to collate texts, a collation set has to be defined by opening the collationer 

and clicking on  in the toolbar. 
2. Select a Project and a title as well as further metadata for the set in the dialog that 

opens now. 
3. Drag text Objects from the Navigator or the Search Results View and drop them into 

the collation set list. Currently, only plain text (.txt) can be collated in this way. 
4. Save the collation set by clicking Crtl+S. 

5. Click  in the toolbar. 
6. The results are shown in a table that aligns all text elements, in a graph of all variants, 

and in the form of TEI-conformant XML. 

4.2.6.2 Standardize the Collation Result 

1. After you have collated different texts, special readings can be defined as equivalent. 

2. Click  or use the link at the bottom of the collation set list to open the equivalence 
set list. 

3. Select a project and a title as well as further metadata for the set in the dialog that 
will appear.   

4. Drag elements from the Alignment Table and drop them into the equivalence set list. 
Tokens that should be treated as equivalent must be dropped in the same line by 

placing the cursor in that line. To delete selected lines, click the icon  in the 
toolbar. 

5. In the second column of the equivalence set list, you can define if this equivalence 
should only be local or global for the whole collation. Click on “Global” or “Local” to 
change this setting. 

6. By clicking the “...” button, existing equivalence sets can be used. 
7. By clicking the “X” button, existing associations with equivalence sets can be 

removed. 
8. Save the equivalence set via Ctrl+S and restart the collation if desired. 

4.2.7 Interaction of CollateX with Other Components 

The CollateX collationer interacts with the Navigator and the Search Results View. Objects 
can be dragged from there to be added to the collation set. The XML result can be copied 
and edited with oXygen or the XML Editor. 
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4.3 MEI Score Editor (Musical Note Editor) 

The MEI Score Editor (MEISE) is a dedicated viewer and in particular a graphic editor for the 
internationally developed MEI notation format, which was designed to satisfy the special 
requirements of musicologists that are unsupported by existing music notation formats. The 
focus of the editor is the creation and modification of MEI documents on a network 
connected client. One of the assets of the editor is the homomorphism of its internal data 
structure to the MEI schema tree, allowing for native support of the note setting process. 
Unique features of the Note Editor arise from the editorial field, such as the visualization of 
variants. 

Basic knowledge of musical notations and terms is a prerequisite for using the MEI Score 
Editor.  For more information, please see 

http://music-encoding.org/documentation/tutorial 

http://music-encoding.org/documentation/tagLibrary 

4.3.1 Install the MEI Score Editor 

MEISE must be installed subsequently to the Lab via the Marketplace. 

4.3.2 Open the MEI Score Editor 

A perspective must be open to contain the Note Editor. The only way to start the Score 
Editor is by opening or creating an MEI document as described below: 

 Create a new MEI note sheet via the toolbar  > Item > MEI Notesheet”. Select a 
Project in the “Create a new TextGrid Object” dialog box. Click “Finish” or “Next” to 
select a title for the new Object. Pressing the button “Finish” will open the Note 
Editor with a simple unnamed MEI document, together with the XML Editor’s Outline 
and Properties View. 

 Click on an existing MEI Item in the Navigator View and the editor will open. 
 Via the context menu: Open the XML Editor Perspective. Choose an MEI Item in the 

Navigator. Right-click it, choose “Open with...” > and select “MEI Score Editor”. 
 In this way, you can also open an MEI Item with the XML Editor in order to work with 

the source code. 

4.3.3 MEI Score Editor Perspective 

The MEI Score Editor Perspective consists of four views: 

1. The Musical Score View on the left. 
2. A Palette which appears simultaneously on the right side of the Score View when a 

document is opened. The Palette can be closed and opened separately via the white 
triangle at the top. 

3. The Outline View in the upper right area. 

http://music-encoding.org/documentation/tutorial
http://music-encoding.org/documentation/tagLibrary
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4. The Properties View on the lower right. The Navigator View from which the Note 
Editor has been started after an MEI Object has been opened appears as a hidden tab 
behind the Properties View. 

The Outline and Properties Views are only opened when an MEI document is created or 
opened or if the XML Editor is open in the background. Both views make it possible to edit 
an MEI Object. 

4.3.3.1 Menu Bar of the MEI Score Editor Perspective 

When you open the Note Editor and make changes in the current document, certain items in 
the menu bar will be activated. 

Edit 

 Undo and  Redo: To undo or redo a change made to a document, click “Edit > Undo” 
or “Edit > Redo”. 

 Delete: Use “Delete” to delete all selected elements from the document. 

 Select All: This item works like Crtl+A and all elements in the Outline View will be 
selected or highlighted. This function is enabled only when no changes have been made. 

Window 

 New Editor: creates a second Score View which opens in a second tab behind the current 
editor field. 

Navigation: allows you to activate and switch between editors. Activated editors can be 
minimized and maximized. You can choose the previous perspective, editor, or view. 

 Preferences: Here you can also change preferences for MEISE under “Meise 
Preferences”, e.g. to require the Lab to use the MEISE perspective when opening a MEI 
document. 

 4.3.3.2 Toolbar of the MEI Score Editor Perspective 

The MEI Score Editor has certain specific functions in its toolbar. This toolbar displays more 
items for editing the MEI note sheet on the left side of the general TextGrid toolbar. 

 “Undo and Redo”: Choose  or  to undo and redo changes made in the 
document. 

 “Zoom Factor box”:   shows the zoom factor (in percentage) of the notes. 
You can change the dimension from 25% to 300%. Please note: The extent of the 
Score View does not automatically fit the level of the zooming factor. To change this 
setting, there are three options: “Page” adapts the size of the note sheet to the size 
of the Score View. “Height” extends the musical notes to the height of the Score 
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View. “Width” sets the width of the music sheet to the width of the field. The zoom 

in and zoom out icons   serve to increase or reduce the size of staves, notes, 
and all musical symbols shown in the Score View. Please note: The extent of the 
Score View does not automatically change with the level of the zooming factor. 

 “Insert Measures”:  allows the user to insert a number of prepared measures into 
the MEI document. Up to 100 measures can be inserted. The user can also define if a 
new section for the new measures should be created or if new staves and layers 
within the new measures should be created. 

 “Insert Staffdefs”:  allows the user to insert specified StaffDefs into the MEI 
document. In a table, all criteria for the StaffDefs can be defined previously, such as, 
for example, the shape of the clef, the key signature and the time signature. 

 “Score Image Export”: Use the photo camera symbol  to create an image of the 
visible section or the whole score. Export your score image as a screenshot (.png 
.jpeg or .gif) to a folder on your operating system. 

 “MEI-prune model”:  allows you to save the current variant configuration of the 
MEI into an unambiguous MEI file without variants to the hard disk. Please select the 
parent folder in the list of the dialog box “Save As”. 

 “Manage Sources”:  creates and edits sources in the current MEI document. 

4.3.3.3 Shortcuts in the MEI Score Editor Perspective 

Del Deletes All Currently Selected Elements From the Document 

Strg+Shift+1 Starts the “Insert Measures” Tool 

Strg+Shift+2 Starts the “Insert Staffdefs” Tool 

Strg+Shift+4 Starts the “Score Image Export” Tool 

Strg+Shift+5 Starts the “MEI-prune model” Tool 

Strg+Shift+6 Opens the “Manage Sources” Dialog 

4.3.4 Musical Score View 

At least one perspective must be open to contain the Musical Score View. As soon as an MEI 
Object has been created or opened, the view will appear. In this area the musical scores that 
you can open from the TextGrid Repository, or create and modify with the Palette and the 
Outline View, will be displayed. 

The encoded note text is displayed in a WYSIWYM View to display the encoding properly. All 
changes in the document can be made in this WYSIWYG-style. The Score View is primarily 
meant for the two-dimensional display of the rendering, as drag & drop operations are 
disabled. Elements in the note sheet should be modified with the assistance of the Editor’s 
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Palette  and the Outline and Properties View . Single elements in the Score View as notes or 
rests can be selected and appear in blue by left-clicking on them. 

More complex interventions in the source code of an MEI document will require the XML 
Editor. To open the source code of an MEI Object, please use its context menu in the 
Navigator and choose “Open with > XML Editor”. 

 

 MEISE Musical Score View 

The context menu is enabled on the Score View, but direct user manipulation via drag & 
drop is disabled. It offers the following options: 

 Undo and Redo  changes . 

 If single elements are selected in the Score View, they can be deleted with . 

 The user can duplicate preselected elements with “Clone” . 
 “Run as > Run Configurations…” opens a new window. There the user will be able to 

create new configurations for the launch and define the settings. 
 You can validate your MEI document by clicking “Validate”. 
 Use some Eclipse-specific options by selecting “Team”, “Compare With”, or “Replace 

With”. 
 To associate an adaptor to your document, please select “Associate an Adaptor...”. 

An associated adaptor can translate the given documents to the TextGrid Baseline 
Encoding. In the new dialog box the selected file is presented with information about 
title, project, contributor, and creation date. You can mark the box below to make 
the assignment persistent when clicking “OK”. In the lower list you can select the 
adaptor by clicking on it. Here you can also receive additional information. To reverse 
your selection, you can mark the button under this list. 

 To save your changes, click  on the bottom of the context menu. 
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4.3.5 Palette 

The Palette will open every time the Score View is activated. It consists of the instruments 
and items which you can use in the Outline View. Practical instructions for using these 
instruments (drag & drop onto the Outline View), are described in the section about “Using 
the MEI Score Editor”. You can hide the Palette by clicking the white triangle at the top right 
or by moving it to the other side of the Score View by dragging it like a view. 

 

4.3.5.1 Features of the Palette 

The Palette  includes a range of icons divided into several groups: 

 Control Group: With the “Select” tool  it is possible to go to any position 
in the note sheet. 

 “Create Staves”:   creates a new group of bracketed or braced right hand 

and left hand staves.  creates a new staff definition, i.e. a container for 
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staff meta-information which includes meta-information about the clef’s pitch, the 
key signature, the label (right hand or left hand), and the time signature. 

 “Create Containers”: “Section”  , “Measure”  , “Staff”  and “Layer”  : this 
group creates new containers in the note sheet which are themselves able to contain 
other data types. All comprised data in a container results in a meaningful whole. 

              

 “Create Events”: “Note”  , “Rest”  , “MRest” , “Space” , “Beam (group)”  

, “Chord (group)”  : this group contains the minimum unit of elements which can 
be created within a musical score in the Score View. 

             

 “Create Variants”: “Apparatus”  / “Reading” :  this group enables the encoding 
of variants, a specialty of the editor for musicological use. 

             

 “Create Additions”: “Create Slur”  “Create Tie”  “Dynam”  : with this element 
group, useful music notation symbols can be added to the score. 
 

 

The pin function on each of the units (“Pin open”, “Unpin”) allows you to maintain the 
Palette state even after restarting the TextGridLab. 
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For more details about the application of the Palette, please see the chapter “Using the MEI 
Score Editor”. 

4.3.5.2 Context Menu of the Palette 

The context menu of the Palette offers several commands: 

 To arrange the workspace layout of the Palette, select “Layout >“. The list 
arrangement of all icons is preselected. You can also choose between an 
arrangement in columns, a display of the icons only, or a list arrangement of all icons 
with details included. 

 If you select “Use Large Icons” the palette actions will use large-scale icons where 
available. 

 You can change some predefined settings of the Palette’s icons: Click “Customize…” 
and a new dialog box will open. All five units and their elements contained in the 
Palette are listed on the left in a tree structure. The bar at the top of the tree 
structure enables you to change the position of the entries in the Palette (“Move 
Down”, “Move Up”). You can also delete single elements from the list. The “New” 
button allows you to create a new drawer. The settings of the Control Group and its 
components cannot be changed. For the other groups there are several possibilities 
to change their preferences. Please tick the boxes to hide the whole unit or just 
single elements of it. For a single unit, you can open the drawer at start-up or pin the 
drawer open at start-up. It is also possible to create or modify the names and 
descriptions of groups and elements. Click “Apply” to apply your changes. 

 To change the settings of the Palette itself, click “Settings…” and a new dialog will 
open. If you click “Change…” you can change the font, its style, color, and the font 
size of the icon captions in a separate window. Otherwise, the default settings will be 
restored. You can choose between different layouts (“Columns”, “List”, “Icons only”, 
“Details”) via buttons or use large icons by ticking a checkbox. There are also options 
for the drawers of the Palette: The default setting is that the drawer will be closed if 
there is not enough workspace. Furthermore, you can decide whether it should be 
closed when opening another drawer or if it should remain open. 

4.3.6 Outline View of the MEI Score Editor 

The Outline View in MEISE has three different functions. First, it facilitates navigation in large 
MEI documents by providing an overview of the document’s tree-structure. Second, as in the 
Properties View it is essential for editing a document because you can build your hierarchical 
MEI tree using drag and drop in this area, and the graphical results are shown in the Musical 
Score View. Finally, it offers a quick switch between the sources in the MEI document (if they 
exist). More detailed information is provided in the section on “Using the MEI Score Editor”. 
Every time you select an element (Measure, Note, Rest, Beam, Tie, Slur) in the Outline View 
via left-clicking, the corresponding element in the Score View will be highlighted in blue so 
that the user always knows the current location within the document. 
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4.3.6.1 Title Bar of the MEISE Outline View 

The Outline View title bar contains a button which enables switching between different 
previously declared sources. These sources themselves define different variants which can 
been seen in the Musical Score View while switching. See “Musical Variants”. The Filter 
function of the title bar is located in the downward triangle. 

4.3.6.2 Context Menu of the MEISE Outline View 

The MEISE Outline View provides the following commands for editing the document: 

 “Undo” and “Redo”  to reverse and restore changes in the document. 

 “Delete”  removes the selection from the document. 

 The “Insert Container/Variant/Event/Additions” operations are only available when 
valid in the selected area (e.g. events can only be inserted into a layer - see the MEI 
schema) and offer quick access to frequently used elements. 

 

 The Measure elements can be relabeled by right-clicking them and selecting “Relabel 

Measures” . 

 The “Clone”  command duplicates the selected element with default initial values. 

 To save your changes, click “Save”  on the bottom of the context menu. This 
button is only active if there have been changes since the last save. 
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4.3.7 Properties View of the MEI Score Editor 

This view shows the modifiable properties of the elements from the Outline View in two 
columns (i.e. attributes of selected elements in the Outline View and their appropriate 
values). 

The information displayed in the Properties View will change depending on the preselected 
(highlighted) element in the Outline View. The properties “ID” and “N” (number) are basic 
and static but their values depend on the preselected element type. If you make changes in 
the Value column, the modifications will be displayed immediately in the Score View. To 
validate all modifications in the Value columns, please click anywhere in the Score View. 

 

4.3.7.1 Features of the Properties View 

Changes in the following value categories have an impact on the editing process: 

(All 
elements) 

color of visual representation (default is black) 

identificator of the element (read-only) 

notes on the element: A string for commentary thoughts 

ScoreDef 
quick access to the properties “Label” and “Notes” of all contained Staff 
Definitions 

StaffGroup 
definition of a symbol that appears at the beginning of the staves. The choices 
are: none, brace, bracket, and line 

StaffDef 

the pitch of the clef can be chosen (G, F, C, GG, PERC, TAB), as well as the clef 
line (1-5) 

the key signature can be determined (0, 1-7sharp symbols, 1-7flat symbols) 
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the time signature can be determined: Meter Count/Meter Unit (for example, 
three-quarter time) 

choose as a time signature symbol: none, common time, or cut time to 
override the numeral display 

the label of the declared staff (e.g. “piano”) 

Measure 
definition of the right and left bar rendition: dashed, double, doubledashed, 
doubledotted, dotted, end bar, invisible, repeatboth, repeatend, repeatstart, 
and single 

Note 

various forms of accidentals can be chosen like s=sharp or f=flat 

the articulation, like acc or stacc. This can be defined via a properties dialog 
box which will open when you click [] > … in the Value column besides the 
property “Articulation”. 

Check or uncheck the intended DataARTICULATION properties in the box. The 
articulation affects the transition or continuity on a single note or between 
multiple notes. 

the number of dots can be specified. 

the note’s value can be specified with “Duration” (“1” for “full note”, “2” for 
“half note” and so on) 

in the “Octave” line the note can be transposed up or down by an octave 
(levels range from 1 to 8) 

define the pitch of the note by the category “Pitchname” (a, b, c, d, e, f, g) 

the direction of the note’s stem can be set upwards or downwards 

the length of the note’s stem can be defined by number 

a timestamp for the event, if not currently being evaluated by the system for 
placement 

a syllable for song text 

Rest 
the duration of the rest can be defined by number, see “Note” 

a timestamp for the event, see “Note” 

Space 
the duration of the event (see “Note”) 

the timestamp of the event (see “Note”) 

Chord 
the articulation can be defined 
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the number of dots can be specified 

the chord’s value can be specified with “Duration” 

Note count is static (default setting “2”) 

the direction of the chord’s stem can be set upwards or downwards 

the length of the chord’s stem can be defined by number 

Apparatus the selected source that should be displayed 

Reading a set of sources connected to this reading 

Slur / Tie 
the curve direction can be set above or below 

the timestamp can be defined 

Dynam 

a place where the dynamic definition should be displayed (above, below, or 
within the system) 

a timestamp, see “Note” 

a value, defining the content of the dynamic definition; some key phrases 
(e.g. “pp”) receive a special display. 

Unknown 
Element 

the name of the element type that is currently not yet supported 

4.3.7.2 Title Bar of the MEISE Properties View 

The Title Bar of the MEISE Properties View offers you several icons to perform a range of 
operations: 

 Click  to pin this property view to the current selection 

 Click   to show all properties of the preselected element in the view (including the 
properties in the “Basic” category) 

 Click  to show advanced properties 

 Click  to restore the default value of a selected property 

 Click the white triangle to open the view menu. The view menu allows you to open a 

new Properties View ,  pin a property to a selection and  show categories and 
advanced properties to define the width of the two columns “Property” and “Value” 
after clicking “Configure Columns…” 

 Click the remaining icons  to minimize and maximize the view 

There is also a context menu in the title bar that is identical to all view title bar context 
menus in Eclipse. 



 
137 4 Subject-specific Tools and Services 

4.3.7.3 Context Menu of the MEISE Properties View 

The context menu in the Properties View allows you to copy and to restore the value of a 
given property. If you click in the text field of the value column, the context menu will be 
borrowed from your operating system. 

4.3.8 Using the MEI Score Editor 

The following text describes how to work with the MEI Score Editor. For this purpose, the 
use of the items of the Palette will be demonstrated and  the properties of the elements 
from the Outline View will be mentioned. Since the MEI Score Editor creates and modifies 
MEI documents, this subchapter follows the hierarchical structure of an MEI document. 

Please note: The manipulation of the score is done in the Outline View or, respectively, with 
the context menu of the Score View. Creation of new elements can be achieved either by 
dragging new elements from the Palette into the Outline View for creation or by using the 
context menu of an element in the Outline View/Score View. When you have marked an 
element in the Outline View, you can also delete it using the context menu or modify its 
properties using the Properties View. 

4.3.8.1 Create and Modify MEI Documents 

A newly-created MEI Item will already display a music sheet in four-four time with only one 
measure and no notes within it. The Outline View and the Properties View will appear, 
showing the structure of the MEI document. For more information about how to open a new 
MEI document, please see “Open the MEI Score Editor”. Now you can create new elements 
for your score. 

Staff 

“ScoreDef” is a default element and not deletable. Under the “ScoreDef” element you can 
create the score declarations “StaffGroup” and “StaffDef”. 

Start with a “StaffGroup”, which is a group of bracketed or braced staves. A “StaffGroup” 
contains lines with clef and time signature. Left-click on a “StaffGroup” element in the 
Palette in the „Create Staves” section and drag it into the “ScoreDef” element in the Outline 
View while pressing the left mouse button. After performing this action, you will see no 
visible results like scores or staves in the Musical Score View since you have not yet entered 
a musical event such as a note or rest. 
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Now you can drag a “StaffDef” element, which is a container for staff meta-information, 
from the Palette on the “StaffGroup” element in the Outline View. In the figure below three, 
“StaffDef” elements have been added and named Staffdef 1, Staffdef 2 and Staffdef 3. This 
figure also demonstrates how to name a staff and other possible options to change or 
initialize properties of the single “StaffDef” in the Properties View. 

 

Container Creation 

The “Section” element is a container for actual music data. “Section” is not a subelement 
from “ScoreDef”, so you do not need to drag it to the “ScoreDef” element. Drag it instead 
into the white space underneath the “ScoreDef/StaffGroup/StaffDef” section. Since it is a 
container and not an event, no visible results will be shown in the Musical Score View. 

Dragging the “Measure” element into the “Section” element in the Outline View will have 
the same (invisible) effect because it is just a container of the content for a measure. 

After dragging a “Staff” element from the Palette on the “Measure” element in the Outline 
View, you see the measure with its staff on the left. In the screen shot below, there are the 
three “Staffdefs” and four measures, called Measure 1-4. To illustrate the fact that the 
staves belong to their measure, the different measures have different numbers of staves. 
Before you start creating notes and rests, a container for those kind of events is required. 
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 For this reason, you will need to create a “Layer” element on the staff in the Outline View, 
as shown in the next figure. You can only add events to a “Layer”, since adding an event 
directly within a staff is not allowed. 
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Event: Note, Rest, Beam and Chord 

As described in the paragraph above, it is necessary to create a “Layer” before you will be 
able to add an event such as a quarter note. 

To create a “Note”, you must create a “Note” element on a “Layer” in the Outline View. The 
default properties (e.g. Duration and Octave 4, Pitchname c) of this note are shown in the 
Properties View. In the figure below the table some properties of the note in the second 
measure, which you can edit in the Properties View, are demonstrated. All editing 
possibilities are listed in the following table: 

Property Explanation 

N Label for a note, only visible in the source code 

Accidental 
Accidental of the note, sharps (s), flats (f), neutrals (n), double sharps (x), 
double flats (ff) and other double accidentals; triple flats (tb), triple sharps 
(xs) and other less common combinations) 

Articulation Articulations such as acc or stacc 

Dots Number of dots 

Duration 1 (whole note), 2, 4, 8, 16, 32, 64, 128 (duration of notes) 

Octave Octave of the note 

Pitchname A, B, C, D, E, F, G as pitchnames 
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StemDirection Up or down 

StemLength Length of the stem (the default is 19) 

Syllable Lyrics under the note, visible in the musical score 

Timestamp a time stamp is defined in the form X.000 

 

In the figure on the left   you can see the result of the use of the property “Syllable” (text 
under a note), which you can modify for every note. It is the beginning of a German 
Christmas song. The value of the property “Syllable” is displayed under the note, to which 
you added this element.  The figure on the right shows an excerpt of its corresponding 
source code in MEI, where you can see the usage of a “Syllable” element. 
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A “Rest” is created in the same way as a note. You will need to drag it onto the “Layer” of 
the “Staff” where you would like to place the rest. In the Properties View, you can change 
the duration of a rest. 

A “Space” is created in the same way as a note or a rest. After adding a “Space” element, no 
visible result will be seen. This element is visible only in the context of use with other events 
because it acts as a placeholder between two events like two notes. The user can also define 
its duration. 

The MEI Score Editor is not only able to show single notes, but also connected ones. For this 
purpose, you will need to drag a “Beam” or a “Chord” from the Palette onto a “Layer”. 
Afterwards you can add notes on the “Beam” or “Chord” element in the Outline View. An 
example for the creation of a beam and a chord is given in the figure below. The editable 
properties of a chord are “Articulation”, “Dots”, “Duration”, “Note count”, “Stem direction”, 
and “Stem length”, and also “Timestamp”. 

 

 Alternatively, you can use the context menu of the Outline View for the creation of new 
elements as children of an existing element. Please use the items “Insert 
Container/Variant/Event” and “Add Additions...” in the context menu depending where they 
appear. Since the MEI Schema has strict rules defining the allowed occurrences of elements 
and their use, the modification of the content must follow certain policies. To guide the 
user's workflow and reduce the learning curve for MEI, the context menu offers a 
convenient subset of the most frequently used elements that are valid for creation at the 
given location, as shown in the figure below. In Windows, adding child elements via context 
menu can only be done when the MEI Object is open in the XML Editor. 
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 When you open an existing MEI document that was not created with the MEI Score Editor, it 
is possible that there will be “Unknown Elements” displayed in the Outline View. Not every 
possible element and attribute from the Music Encoding Initiative data format has been 
implemented (yet) into the MEI Score Editor. These elements and attributes are not being 
erased or ignored by the editor, but instead they are represented as an object with a 
question mark titled “Unknown Element”. Furthermore the name of this unknown element 
is shown as a property in the Properties View. For an example, please see the last figure 
below. In the source code of the MEI document, the four staves of the example have a 
fermata in measure 4, which can not (yet) be displayed by the MEI Score Editor. 
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4.3.8.2 Musical Variants 

The MEI Score Editor also provides a digital representation of musical variants. This is 
necessary because of the limits of the presentation of variants in printed media. While the 
MEI Score Editor offers the opportunity to switch between different variants, the encoding 
of variants should be done with the “Apparatus” and “Reading” elements. 

Apparatus and Reading 

In the figure on the left  the use of the app (Apparatus) and the rdg (Reading) elements are 
shown in the MEI source code and on the right the corresponding Outline View, where you 
can see how to insert the “Apparatus” and “Reading” elements into the hierarchical 
structure. 
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Declare Sources 

To use the possibilities for presenting different variants, you will have to declare sources for 
the readings. The definition which “Reading” belongs to which source is already visible in the 
source code in the attribute of each rdg element. Before you will be able to define the 
sources, you must declare them in the following way: Click the “Manage Sources” button on 
the toolbar of the MEISE Editor, which was already mentioned in the “Toolbar” paragraph. A 
new dialog box will open, as shown in the figure below. Here you can create sources by 
clicking the “Create New” button. Now you can give your source a name or modify the 
“Label” and “N(otes)” attributes. After clicking the „Close” button, your sources will be 
saved. 
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Define Belongings 

The next step is to define which source belongs to which reading. For this purpose, click on a 
“Reading” element in the Outline View and then open the value of its property “Rdg 
Sources” in the Properties View. As soon as you click the properties editor in the value 
column, a new dialog will open. Select a source from the available sources you have declared 
and click the „Add Source” button. You can also add more than one source to a “Reading” 
element and you can also use the “Remove” or “Remove All” buttons. After clicking the 
„Close” button, your modifications will be saved. For an example, see the figure below : 
here, every “Reading” element has one corresponding source. 
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Show different variants 

After you have added the sources to the readings, you can switch between the different 
variants. Click on the “Apparatus” element in the Outline View and select a source you want 
to see in the Properties View. In the last figure, the “SourceForVariant_2” is selected and 
displayed in the Score View. The selected source is also highlighted in green in the Outline 
View. 
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4.4 Digilib 

Digilib (short for “digital image library”) is an open software tool for the scholarly study of 
images via the internet. It was developed to enable the study and annotation of images. High 
resolution digital images are stored and processed on an image server and only a small 
visible part of the image is transferred over the internet. 

The user can zoom, rotate, mirror, enhance, and annotate images in a persistent way 
without changing the original image data. The Digilib software facilitates two aspects of 
scholarly work with digital images: First, it provides a means of exploring and analyzing 
images in high-resolution detail. Second, it provides the opportunity to cite and reference 
research results with the aid of explanatory elements and references in the image or in 
image segments. 

The Digilib plugin in the TextGrid Laboratory implements the functions for image display, 
zooming, scaling, rotation, and mirroring as well as color modification. The current zoomed, 
rotated, or mirrored view of the image can be saved as a Digilib View object and opened at 
any time. 

For more information, please see 

http://www.mpg.de/410783/forschungsSchwerpunkt1 

http://zuccaro.biblhertz.it/dokumentation/digilib 

http://digilib.berlios.de/ 

4.4.1 Install Digilib 

In order to work with Digilib, you must first install it to the TextGridLab via the Marketplace. 

4.4.2 Open Digilib 

To open images in Digilib, select “Digilib” in the context menu of an image in the Navigator. 

The image is now shown in the Digilib Editor. When the Digilib Editor is open, several 
buttons to modify the image will be shown in the toolbar. 

For more advanced editing options, you will need to open the Properties View. You can 
either open it indirectly by starting the XML Editor in the background or select “Tools > Show 
View > Other… >“ in the menu bar. As soon as the “Show View” dialog box opens, a row of 
folders will be displayed. Open the first folder named “General” and choose “Properties”. 

Click on the image in the Digilib Editor and the properties for editing will open. Now your 
workbench is complete. 

http://www.mpg.de/410783/forschungsSchwerpunkt1
http://zuccaro.biblhertz.it/dokumentation/digilib
http://digilib.berlios.de/
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4.4.3 Components of Digilib 

Digilib consists of the Scaler service and the Digilib Client. 

The Digilib Scaler Service 

The Digilib Scaler service is a webservice running on a TextGrid server that receives 
commands from the Digilib Client in the TextGridLab and communicates with the TextGrid 
Repository. The Digilib Client tells the service which image to display and which image 
operations to perform and the Digilib Scaler service returns the requested image. 

The Digilib TextGrid Client 

The Digilib TextGrid Client is a plugin module for the TextGridLab that lets the user display, 
modify, and annotate images. The Client communicates with the Digilib Scaler service. 

4.4.4 Digilib Editor View 

The Digilib Editor View shows the image in the size and resolution of your screen. When the 
Editor is open, you will also see additional Digilib Toolbar buttons in the Toolbar on top of 
the window 

With the Toolbar buttons you can zoom in to inspect the image up to the highest resolution 
offered by the server or rotate or mirror the image or change its brightness or contrast. 
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On the toolbar of the TextGridLab GUI, a row of icons or buttons will be displayed as soon as 
the Digilib Editor is open. 

 ScaleUp/ScaleDown: The image can be scaled down or up, meaning that the overall 

size can be reduced with  or enlarged with   . 

 ZoomArea: after clicking the button   you can zoom into an area on the image by 
first clicking on the upper left corner of the area and then the lower right corner. 
After the first click, a red rectangle will appear and indicate the currently selected 
area. After the second click, the image will be replaced with a zoomed view of the 
selected area.  

 ZoomFull: The button  zooms out and shows the whole image. 

 Rotate: The button   opens a slider control to rotate the image. 

 Mirror Vertical: The button  mirrors the image vertically (top-down) 

 Mirror Horizontal: The button  mirrors the image horizontally (left-right). 

 Contrast: The button  opens a slider to change the contrast of the image. 

 Brightness: The button  opens a slider to change the brightness of the image. 

These buttons present the most important functionalities that can also be operated by the 
advanced controls in the Properties View. 

The current state of the image in the editor can be saved as a Digilib Editor View Object in 
the TextGrid Repository and recalled at any later time. 

4.4.5 Digilib Properties View 

The Digilib Properties View offers a range of advanced facilities to work with an image. 

 The “Image Information” property shows data items including the original height and 
width values of the image on the server. These values can not be changed. 

 The “DPI” property provides the resolution settings of the client display. These 
properties are used for the original-size scaling feature only (put “osize” in mode 
flags under “Rotation and Mirroring”. The default display resolution setting is -1. The 
values can be changed. Click the button “redraw” to set the changes in the Image 
Editor. 

 “Rotation and Mirroring” is the next column. The flags for the mode of operation can 
be changed here. The default setting is “fit”, which means that the image is scaled to 
fit the screen. Another value is “clip” which does not scale the image but only shows 
a cropped portion. The rotation angle of the image can also be set manually. Click the 
button “redraw” to see the changes in the Image Editor. The image is rotated 
clockwise by the respective angle in degrees. 

 “Color” enables the user to change the colors, the brightness, and the contrast of the 
image. There are two ways to modify the color. Different numeric values in the three 
coordinates lead to changes in color intensity and color shade: 

o by addition (RGB): This property works like the brightness slider for each color 
channel and adds a value to each pixel color. The three coordinates stand for 
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the primary colors red, green and blue. The values can range from -255 to 255 
(and larger if multiplication is used). 

o by multiplication (RGB): This property works like the contrast slider for each 
color channel and multiplies the value of each pixel color. Here the user can 
vary the saturation level of the primary colors red, green, and blue in the 
image by modifying the coordinate numbers. The values can range from -8 to 
8. 

o The value of overall brightness can be modified by a numeric value also. This 
value is added to all pixel color values. Positive values will make the image 
lighter, and negative values darker. The values can range from -255 to 255 
(and larger if contrast is used). 

o The overall contrast can also be changed. This value is multiplied with all pixel 
color values. Positive values enhance the contrast, and negative values reduce 
the contrast. The values can range from -8 to 8. When you increase the 
contrast in this setting you must compensate for the increased overall pixel 
values by negative brightness values. The contrast slider in the Toolbar does 
this automatically. 

 “Size and Scaling” offers several opportunities to change the zoom area (relative 
height, width and offset) and overall size of the image (destination height and width): 

o relative height of the zoom area as a fraction of image height. Value 0-1. 
o destination width of the image in pixels 
o additional scaling factor for the destination size which allows the user to 

enlarge the whole image 
o relative y offset of the zoom area as a fraction of image height. Value 0-1. 
o relative x offset of the zoom area as a fraction of image width. Value 0-1. 
o destination height of the image in pixels 

The context menu is disabled in the Properties View. Click on the respective symbol on the 
toolbar to pin the selected Property View to the current selection. The downward triangle on 
the right offers the possibility to open a new Properties View or likewise to pin the Property 
View to the current selection. 

4.4.6 Interaction of Digilib with Other Components 

Digilib can be used to edit and save pictures before linking them to XML documents in the 
Text Image Link Editor. 
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5 Conclusion 

This manual covers the basic information and support for working with TextGrid. Since 
TextGrid is designed to support continuous expansion and further development, guides and 
information about additional tools and services will be added as they are developed and 
integrated into the TextGridLab and Rep. Please contact us at info@textgrid.de if you would 
like to provide comments, suggestions, or feedback about this manual or about TextGrid in 
general. 

TextGrid is an open source project developed to suit the needs of humanities scholars 
working with text-based research. Since the priorities of TextGrid are to support 
collaborative digital research methods and to encourage reliable and secure data curation 
practices both now as well as into the future, our user community is essential in determining 
the future of TextGrid. We encourage you to participate in contributing to TextGrid. Our 
primary user groups consist of the following three categories: 

 If you are a member of a research project, we are interested in working with research 
projects to develop additional applications that fit their requirements. Please contact 
us if you are interested in exploring the options available for your project. 

 If you are a developer and have developed an application that you think would be 
suitable for use in TextGrid, please let us know. TextGrid strongly encourages the 
integration of external tools and services, and we will be happy to discuss the 
technical requirements and possibilities with you. 

 If you are a content provider, such as an archive or research institution, and you are 
interested in making your content available in TextGrid, please contact us in order to 
explore the ways in which we can work together to enable access to your data 
through TextGrid. 

Welcome to TextGrid! 

mailto:info@textgrid.de

